Can't import WAV files from Hydrogen

After a major hard drive crash I’ve had to start again from scratch, upgrading from Windows 7 to 10 and reinstalling the latest versions of Audacity and Hydrogen. I have exported a song from Hydrogen in CD quality (44.1khz, 16 bit PCM) to separate WAV files, however Audacity won’t open them. A pop up told me I needed the latest ffmpeg library to allow it to open the files which I have installed, but Audacity still doesn’t recognise the file type. What am I doing wrong here?

Something is “wrong” with the file… You don’t need FFmpeg for regular WAV files, but do you have it installed?

The file could be corrupt or it might be a different format. Check the format with [u]MediaInfoOnline[/u].

You can also check the file size - A regular CD quality file is about 10MB per minute, or half that if it’s mono.

If it’s uncompressed PCM (with a missing or bad file header) you can import it as RAW data. (File → import → Raw Data). You (hopefully) know most of the parameters. The default endianneass should be OK and you can start with a offset of zero. If you get corrupted audio try an offset of 1. With 16-bits an odd or even offset should work. If it’s stereo and left & right are reversed, increase the offset by 2.

Raw import ONLY works with PCM. Compressed audio won’t be decompressed/decoded and it will sound like pure noise…

The offset is where the header is supposed to end and the audio starts. If there’s a (corrupt) header a low offset will read the header as audio and create a glitch (jut several bytes) which you can edit-out.

Hi and thanks for the prompt reply. I’ll be honest the second part of your answer mostly flew right over my head (if you were wondering what that whooshing sound was), but I did check the files with the link you provided. It didn’t say there was anything wrong but it did tell me the bit depth was ‘8’. The thing is Hydrogen allows you to set the bit depth in the export options (as well as many others), and now I’ve changed it to ‘16’ all is good with Audacity!

and now I’ve changed it to ‘16’ all is good with Audacity!


…Just FYI - Audacity can open (or save) 8-bit WAV files (in case you didn’t already know that) so that wasn’t the only problem. But you probably don’t want (low quality) 8-bit files anyway.