Can't import Opus files in 2.4.1, worked fine in 2.3.0


I recently upgraded my Audacity installation from 2.3.0 to 2.4.1 on Mac OS Mojave 10.14.6. I got a popup on first run informing me I needed to reinstall ffmpeg, which I understand is due to the switch to 64-bit. It appears to be configured correctly now, but I’m not able to import an Opus audio file any more. I think the ffmpeg installation is set up correctly, I tried a WMA file and it imported fine. I can find lots of threads about Audacity lacking Opus export support, but everyone seems to say that imports should work fine (and they used to). Here’s the relevant bits from the log…

18:05:50: Audacity 2.4.1
18:05:50: Trying to load FFmpeg libraries...
18:05:50: mLibAVFormatPath ('/Library/Application Support/audacity/libs/ffmpeg.55.64bit.dylib') is not empty. Loading from it.
18:05:50: Checking for monolithic avformat from '/Library/Application Support/audacity/libs/ffmpeg.55.64bit.dylib'.
18:05:50: avformat not monolithic
18:05:50: Loading avutil from '/Library/Application Support/audacity/libs/ffmpeg_utils.52.64bit.dylib'.
18:05:50: Loading avcodec from '/Library/Application Support/audacity/libs/ffmpeg_codecs.55.64bit.dylib'.
18:05:50: Loading avformat from '/Library/Application Support/audacity/libs/ffmpeg.55.64bit.dylib'.
18:05:50: Actual avutil path /Library/Application Support/audacity/libs/ffmpeg_utils.52.64bit.dylib
18:05:50: Actual avcodec path /Library/Application Support/audacity/libs/ffmpeg_codecs.55.64bit.dylib
18:05:50: Actual avformat path /Library/Application Support/audacity/libs/ffmpeg.55.64bit.dylib
18:05:50: Importing symbols...
18:05:50: All symbols loaded successfully. Initializing the library.
18:05:50: Retrieving FFmpeg library version numbers:
18:05:50:    AVCodec version 0x373466 - 55.52.102 (built against 0x373466 - 55.52.102)
18:05:50:    AVFormat version 0x372164 - 55.33.100 (built against 0x372164 - 55.33.100)
18:05:50:    AVUtil version 0x344264 - 52.66.100 (built against 0x344264 - 52.66.100)
18:05:50: FFmpeg libraries loaded successfully.
18:39:18: Mime type is *
18:39:18: Opening with libsndfile
18:39:18: Opening with liboggvorbis
18:39:18: Opening with libflac
18:39:18: Opening with lof
18:39:18: Opening with libav
18:39:18: Error: FFmpeg : avcodec_find_decoder() failed. Index[00], Codec[4f505553 - opus]
18:39:18: Error: Importer::Import: Opening failed.

What should I try next to get this working again?


Thanks for this report theGrue - for a start it helped me catch a definite regression bug on Windows with the latest 2.4.2 alpha test build I have

Your case here on Mac is also logged (for now anyway) in the same bug thread. I cannot test on my Macbook Pro as far back as 2.3.0 (as I have Catalina and it only allows running of 64-bit apps). But it fails on 2.3.1 through 2.4.1 in the same way giving me this error message:

Error Importing
Audacity did not recognize the type of file …
Try installing FFmpeg. For uncompressed files, also try File>Import>Raw Data

On 2.4.2 alpha on Mac I get a different message - but the same as I get on Windows:

MP3 Decoding failed
CRC check failed

though why it’s complaining about MP3 when I’m trying to import OPUS baffles me.

I have logged this serious bug:
OPUS import fails

Once again many thanks for the report, much appreciated.


Same problem here on Linux with Audacity 2.4.2 (though it works on Linux with 2.4.1).

Wacxylinder has logged it as “P1” (priority 1), indicating that it must be fixed in the next release.

Can you wait for a fix? Hopefully it won’t be more than a few weeks until a “Release Candidate” is available.

No problem, thanks for the quick response. Have been using opusdec to convert to wav before import for now.

I originally logged this as part of Bug #2484
Win/Linux: Opus import fails

But in looking at the bug the developer who fixed it pointed out that the Mac import failure was down to a different cause than what was affecting Windows and Linux.

Accordingly I consolidated the Mac part into previous bug #2381 (which was formerly just about lack of Opus export on Mac)
Mac: Export to Opus (OggOpus) is not available on Mac - Opus import fails on Mac

As the import part of this big is a regression on 2.3.0 I have upped its priority to P2 - I added theGrue’s workaround to the bug, thanks for that theGrue.