cant hear while i am recording

hi,
I can still hear the playback after im done recording, but I can no longer hear through my speakers or headphones WHILE I am recording my bass, plus with my effects / filters, etc, although I WAS able to do this previously (up until a few months ago.)
thanks so much for your help!
–alex

Audacity > Edit > Preferences > Recording: [X] Playthrough (select)

If Audacity points to a valid sound playback device (speakers, headphones), that should do it.

I would expect that pathway to have a delay in it. A sound will go to your headphones a beat late after you play it. Are you overdubbing? Are your headphones plugged into the computer or something else?

Koz

koz,
thanksk for the reply. audacity (which I use on windows 7) does have a playback device, with several settings. however, none of them seem to make a difference, when I change them.
what’s worse, I now cant seem to record anything using my effects pedals (delay, envelope filter, loop pedal.) this happens when I am overdubbing or not. my headphones (or speaker) are plugged into my computer.

It’s at this exact place you need to get obsessive. Which Pedals? Model numbers? How are they connected? How is the bass connected? Are you using MIDI with another application? Do you have and use Skype? Which Audacity do you have, all three numbers? Audacity > Help > About.

Can you point to one time or event where it stopped working? (Nobody can ever do this, but we have to ask.)
Koz

koz,
im using a behringer digital delay, model dd400
and a boss loop station a5a7209
and a digitech bass synth wah x-series
note: the problem still exists when I use replacement delay pedals and bass synth pedals, although I don’t have those model numbers, because they were borrowed.
I am connecting all of this through the third plug on the right(1/8th inch) on the back of my Compaq Presario.
I really cant remember an exact time or a particular event that might have changed the settings which, as I say, did work prior to a couple of months ago.
thank you so much for your help!
–alex
ps I am using audacity version 2.1.0

third plug on the right(1/8th inch) on the back of my Compaq Presario.

Sooooooo close.

Is it blue?
Is the logo a fan with an arrow pointing in?
Which Presario? the Presario CQ60 only has two connections back there.

Koz

no, the third 1/8th’ plug is in the row (where I plug in the mic or instruments) is pink, with a mic icon to it’s lower left.
the middle plug in that row (where I plug in headphones or speaker) of 3 is yellow, with an arrow pointing up next to it.
the last plug in the row, the one on the far left, is blue, with an arrow pointing downward.

on the front of the computer are 2 usb ports and 2 more 1/8th’ plugs, one with a mic icon and the other with a headphones icon, but they don’t work any better than the ones on back, as far as the effects are concerned.

there is a sticker on the bottom of the computer (which I fear may be an imitation / knock-off) which says cq500. there are a bunch of upc symbols, stickers, and other numbers, which I would be happy to list if they would help out.

The blue one is intended to be the entertainment stereo Line-In connection suitable for cassette machines, stand-alone CD players, radio tuners, etc. etc. The instrument (pedals, guitar) cables (adapted from 1/4" to 1/8" should be a cousin of that. As an experiment, I took my scopes and instruments to a friend’s house and connected them to his electric guitar. If I hogged down on a chord hard enough, I could get the same signal as a piece of entertainment equipment. Pretty powerful stuff.

You should not connect an instrument to the Pink Microphone In. First, the connection is usually mono, not stereo and it’s easy to get the volume so loud that the connection overloads and starts sounding crunchy. Microphone signals are really tiny compared to the powerful stuff coming out of a guitar or pedal.

So yes, plug the microphone into the Pink Mic-In, the pedals into the Blue Stereo Line-In and the headphones into the yellow. That one doesn’t follow the color convention. You sure it’s not Green? Green is a headphone connection.

You should be able to switch the connections in the Windows Control Panels and make Windows “pay attention” to the microphone or the pedal. This is all before you even turn Audacity on. The Windows control panels should have a light blue bouncing sound meter that tells you the connection is active. In general, if you can’t get it that far Audacity isn’t going to help you. Audacity gets its sound from Windows.

These are the manual entries for First Recording and how the connections work. I’m not a Windows elf.

http://manual.audacityteam.org/o/man/record.html

Scroll down to the bottom and there are more branching tutorials.


One more note. Connecting a guitar or pedal to a blue stereo Line-in will not give you a stereo instrument. The instrument will only record as Left in a stereo track. That’s easily fixed in Audacity.

Koz

koz,
that sounds like solid advice about the using instruments with the blue plug, thanks.
as far as the windows control panels, I still haven’t found which category I need, with the meter to tell me it’s working. I will write back, possibly in a day or two, to let you know if ive located whatever needs changing in the windows control panel.
but im glad that at least I know the problem is isolated to that area.
thank you again so much for your help. ive been trying to fix this forever.
–alex

It always helps us if you state your version of Windows (see the pink panel at the top of the page).

For Windows Vista and later, see Missing features - Audacity Support.

Even a “Mac elf” like Koz can post that link.

Gale

MY PROBLEM IS ALMOST SOLVED.
I went to edit > preferences > recording, then clicked ON “software playthrough,” which now allows me to hear everything, including the effects, while I am recording them.
but there is one last problem: for some reason, when I use any of the effects pedals, I hear(and it is recorded) a low PULSE sound that I cant get rid of. the pulse sound continues until I stop recording. do you know how I can get rid of this pulse sound?
thanks again so much for your help,
–alex

So did you have this pulse sound two months ago when it was originally working as you wanted? Or did you not have the pedals then?

What connects all the pedals and synths to the 1/8 inch blue line-in on the computer?

Are you sure you have set Device Toolbar to record from the line-in? And are you sure you don’t have “Listen to this device” enabled for the line-in in Windows Sound? Note you still have not told us what version of Windows you have. :wink: It just makes it harder to help you when you don’t say.

You could post an audio sample of the noise if it gets recorded.

Gale