Can't hear myself when overdubbing using a Behringer Q802UB

I need some help in how to hear myself through headphones when recording using a Behringer Xenyx Q802USB with Audacity while listening the playback. Thanks in advance.

Press 2-TR to Phones and make sure Audacity is set up for overdubbing…

… and that Audacity is set to play to your USB Xenix, not the built-in speakers or headphones.

You may need to check this one in Windows, too.

I’m guessing what’s what the button does. The instructions aren’t the clearest.


Thanks for the info. I just did it and I can hear myself through the headphones but there is now a delay in the sound. How can I avoid this?


Are you hearing yourself late? If so, turn off Transport > Software Playthrough in Audacity.