Can't hear my recording to harmonize

I have been using audacity for a while not for anything serious- just to record myself and figure out where I want harmony etc. Feedback etc doesn’t bother me
I have always used the microphone from my pc
All of a sudden today, I can’t hear my recording when I press ‘record’.

I will record myself and hear myself quite well, but when I press record again, I hear nothing, and I have to guess when I should start harmonizing.
I used to be able to hear myself in melody and then harmonize two or three parts quite easily because I can hear it in playback (using the record button)
Now the only time I hear myself is if I press the play button, but then I can’t record to it

Why is it working differently, is this the new way to record or do I need to adjust something in audacity to hear the same track when I press record - not just when I press ‘play’

Please please please help me. I have to be in the studio this month and want to make sure I can play around with harmonies before stepping into a studio
Thanks in advance

Frustrated and Desappointed

I have the same problem. When I go to preferences under the EDIT tab then recording I tick the box Playthrough… Other tracks while recording (overdub). I thought this would do it but then when I try to record, the new track is added but nothing records. This is new since I recorded some songs last fall.

Name is Bob and I can use some help. I have made some progress.
Now when I record the second track I can hear the sound through my main external speakers. This is not good as it picks up when I record the second track vocal or my guitar through my amp, etc. BUT when I switch to Speakers: Line Audio iONE box, my Presonus box, it will not record at all. Or an error message shows up saying the recording is hidden before 0. I can’t seem to find anything. Frustrating.

You can get symptoms like this if you have the wrong devices selected. If you like to record YouTube or other on-line content, there are system and Audacity settings that allow you to do that, but those settings do not work in Overdubbing.

It’s something of a time bomb. Recording “All the Stations” theme song from YouTube on Monday will cause Overdubbing to fail on Thursday.

The two windows for recording and playback in the menu bar have to be real things, and it’s unfortunately complicated by the data name for a device which can be different from the real life name. For example, my Behringer UCA-202 stereo interface arrives as “USB Audio CODEC.”

And that’s not nearly complicated enough, so whatever you do has to appear in Windows Control Panels, too. Audacity gets its sound from Windows, not the device itself.

So right-click the little Windows speaker lower right > and drill down to recording devices and playback devices and make sure the right things are selected. In the case of recording, the Windows sound meter should jump when you make a sound.

If you can’t figure out which device is which, note the devices appearing there and then disconnect the microphone. See which one vanishes.

After all that, open (or re-open) Audacity and make sure the same things are selected in the tiny microphone and speaker boxes.

Now go into recording preferences and select Overdubbing and not playthrough.

See if everything works.

That’s simple overdubbing where you hear everything but yourself. No mix.

For perfect overdubbing where you hear your own voice in theatrical mix, that needs your headphones plugged into your microphone (if it will do that) or preamp/interface. Generally, you can’t listen to the computer because of echo and delay problems.

And since you’re in Windows, this can get more complicated yet. Turn off Windows voice processing if you haven’t already. Windows likes to process your voice for Conferences, Chat and Communications. The processing hates music.


Note if you do disconnect or unmount your microphone or interface and plug it back in, you should restart Audacity because it will forget what the microphone was. You can also Transport > Rescan…

Audacity automatically scans on start.