Can't get Mic and music together in headphones


Windows 7 64bit, Latest version of audacity installed as of Jan 2016, using “Cue” for dj software.

Issue is when using a Citronix SMFX 200 mixer with 2 USB ports plugged into the PC and using Numark’s “Cue” configurable dj software for playing the music and latest version of audacity for recording it, I can’t hear my voice with music in the headphones together without echo issues or voice/music audio being too low. If I click “Listen to this device” in the appropiate properties window, I can then hear voice audio in the headphones but with echo. To cure this MIC volume levels are lowered in properties which helps but when music audio is added, when speaking, voice audio is then drowned out virtually. The mixer is equipped with a “talkover” function lowering the music by 14db but this does not help. Adjusting all volume levels both MIC and music audio to get it right to kill the echo (or have music audio at a level audacity can record) yet still hear music comfortably either leaves one or the other inaudible for recording. When plugged in, I have in windows settings to detect the mixer reads as USB Audio Codec 3 and USB audio codec 4. Playback is normally 3, recording is 4. I use windows “Wasapi” as output. By switching off “Listen to this device” loses Mic audio. I have tried settings with both “Software playthrough and record other track while playing new one” on and off. Works better with Software playthrough on though but still the echo remains. Any thoughts appreciated.

Whether it is “latest” depends on where you got it from. Please tell us the version number from “Help > About Audacity”.
The current version is 2.1.2 and is available here:

If your voice is being played through the computer, there will inevitably be a delay due to the time it takes for the signal to go through the computer. “Listen to this device” and “Software Playthrough” are both passing the sound through the computer, so neither of those options will give you completely delay free monitoring (“zero latency monitoring”).

To achieve zero latency monitoring, you need to configure your hardware so that the mic input is routed through to your headphones in the hardware.
Plug your microphone and headphones into your mixer, don’t start Audacity (Audacity is irrelevant to this), and find the magic combination of controls that allow you to hear the mic through the headphones. The manual for the mixer will probably be helpful.

When you’ve got that working, try again with Audacity, and ensure that “Software Playthrough” is off (not selected).

Do you really have 2 USB leads going to the PC?

“I detect an RTFM problem here”, I figured. Only, there’s no mention AT ALL in the manual what this second USB should be used for. In fact, the manual is for people who don’t read the manual. To make matters worse, they’re both called “USB input”.

Connecting both might have strange effects on Windows. But I don’t know. Never seen a setup like this and a lot of people seem to have trouble with this mixer and return it quickly after the buy.

“Mixer”. The clue is in the word; mixing 2 or more audio sources together.

I would encourage you to do the following; try to confine yourself to providing answers, rather than posing additional questions of the confused OP who is trying to fix his problem, not your grey areas.