Can't get LAME 64 bit link to open

Hi, I’ve been keeping an eye on the forum here for a month or so now to see if anyone else is having a problem like this but it seems not!

After I updated Audacity to the latest version, ever since, I’ve been trying to update LAME to the 64 bit version too, but the link do do that within Audacity (and anywhere else I’ve been looking for that matter!) doesn’t work-it times out. I’ve tried clearing my browsing history, trying through different browsers-everything-currently it means I can’t use Audacity for mixing my audio tracks at all which is really frustrating.

I’m not overly techie but can normally muddle my way through most problems, but this one has be stumped!

I’m on Mac Mojave 10.14.4
Screenshots attached of what is happening.

Please can anyone help fix this?
Screenshot 2019-04-18 at 11.54.08.png
Screenshot 2019-04-18 at 11.54.18.png

I’ve just tested the LAME download webpage, and it’s working fine.

That’s so weird-I just tried directly from the link you posted and still nothing!

Steve’s link works fine for me too :confused:


There’s a website here that checks the state of websites:

Great link for future reference steve, it’s obviously just me! I’ll see what I can figure out around it.

UPDATE: It was something to do with my wi-fi settings, or privacy/firewall settings. I tried it from my hotspot from the 4G on my phone, it worked!

Thanks everyone who helped out!