Can't find out what's wrong.

Running windows 10 hp all in one.
I’m sure this has been asked and answered many times , but I’m not sure if it’s an issue with audacity or my PC. I’ve overdubbed so many times I can’t tell you. Now , I record my first track , everything is fine. When I go to record my second track , (on another track) , the recording gauge ( line) or whatever it’s called just freezes. Nothing. Doesn’t budge. I’ve tried recording with the transport option ON overdub (nothing) and with it OFF overdub (again it is just frozen. I’ve rescaned audio devices with nothing happening. In the rare chance it does move (and I can hear my 1st recording ) I can not record over it. I’m not sure if I’m setting something wrong , or my PC is getting its signal crossed. Any help would be greatly appreciated. Thanks for your time and any help you think of.

Any error messages?

Overdubbing is an odd duck because for it to work right, the entire record system and the entire playback system have to be working perfectly.

Have you started using Skype or Zoom? They take over the sound system without telling you. Make sure they’re completely closed and if there’s any doubt, clean shutdown the machine. Shift+Shutdown > Wait > Start. Not Start and Not Restart. This one will take longer because it resets more things.

Are you using Network or Cloud drives now? Audacity doesn’t like those very much.

Are you using Audacity in English?

I’ve overdubbed so many times I can’t tell you.

Try. Are you filling up your machine? If you have a spinning metal hard drive, it will slow down as it fills up. Trying to real-time play and real-time record on a sloppy hard drive is not pretty.


If you are still having problems, here are some things to try:

  1. Check that Audacity’s project rate and track rate (in lower left corner and left of track), and Windows recording rate and playback rate are all at the the same speed (run mmsys.cpl). This is typically 44100Hz or 48000Hz.
  2. Switch between MME and WASAPI. (WASAPI requires an active audio source).
  3. Switch between recording 1 and 2 channels.
  4. Switch between Record and Shift-Record.
  5. Make sure Sound Activated Recording is turn OFF.

I have never tried Skype or zoom. Don’t think I’d know how to. My computer is only a little more than a year old and has plenty of space. I believe I am on a network (I’m @home and use my TV & internet connections.). I am using in English. I’ve checked all my rates & speeds , all are in sync.i have not tried switching from MME to WASAPI. I will do that next.i apologize for being a little slow @ this , but what do you mean recording on 2 channels? I have a M-AUDIO 192 /4 interface and not quite clear on how to do that. I make sure sound activated recording is off. I am reading up on shift recording now. Il let yo know how that goes. Thank you very much for your help and patience .

This is simply the stereo/mono choice in the Device Toolbar

Sorry bout the long delay. Things got a little busy round here. I really don’t know what happened. When I came back on a few days later , it was just working again. Thanks for you`re support and hangin in there with me.

Glad to hear it is all working now. :smiley: