Can't export MP3, Audacity can't "see" the LAME lib [SOLVED]


New to Audacity
OSX 10.9.2
Audacity 2.0.5; installed (yesterday) from .DMG

In order to be able to export projects in MP3 I downloaded the LAME library (v3.98.2) .dmg and followed default installation instructions.

The library has been installed in /usr/local/lib/audacity, which is, I think, where Audacity expects it to be. However Audacity can’t access the library. I believe there is an access rights problem. Myself, in Terminal, to list the contents of /usr/local/lib I have to sudo the command … When I run Audacity>Preferences>Libraries the Browse button suggests by default that the Lame library is in the above location; I click OK, but that doesnt’ seem to have any effect.

I am currently trying to run Audacity from an account that has admin rights, but when I’ll handover its usage to my wife Audacity will have to run from an account that has no admin rights.

Any help available? Thanks very much in advance.

Apple sometimes locks out /usr/local by default, even to admins. Apple won’t say how or why this happens but justify it by saying that it is a “dangerous” location for users except root to access.

That may be the case for standard users, even if Apple are not locking the folder.

The solution Apple recommend is to access the folder using Go > Go to Folder in Finder. Then right-click over /usr/local/lib > Get Info.

In the bottom of the window that opens, add rights for the admin group to read the folder.

If you mean the text box in “Locate Lame”, that only says where Audacity is looking. Editing that box has no effect - you have to use the “Browse…” button then select and open “libmp3lame.dylib” (if the folder is not locked out).

If you “MP3 Library Version” in Libraries Preferences says “not found” rather than LAME 3.98.2 then you cannot export MP3.

Then I suggest you use the zip of LAME and extract it to a location that does not require privileges. Please see: Audacity Manual .


Thanks very much for all this info.

I had to tweak a number of things re visibility flags and permission rights but the good news is everything now works just fine.