Can't change speed by small amount of samples

I’m trying to align 2 tracks from different sources that have slightly different speeds. I’ve determined that one of the tracks needs a speed decrease by about 77 samples, but when I try to do that with “change speed”, and press OK, the dialog just disappears and nothing happens. In theory there should be nothing stopping me from doing this, but it just doesn’t seem to work at small amounts.

What I’d like to do:

Audio file:

77 samples is in a 48kHz-track less then 1.5msec of audio.

Just assuming…both Audio-tracks have a length of only 1sec (or more) , this makes a difference of only 0.15% or less.

If your Audio has a normal length of approx. 2minutes or more , this makes a difference of 0.0015% or less.

So this “Speed difference” is not audible. A latency/difference below 10msec is never audible. Also two musicians standing 3 meters away from each other have already a “latency” of 10msec

I think also a speed correction fft-algo needs a minimum size of 100msec-(=4800) Samples to explore frequencies and manipulate them. I guess the final result track can vary in length ±10msec.

It works for me with Audacity 2.4.1.
Which version are you using?

Yeah I forgot to mention I was using 2.1.1. Updated to 2.4.1 and now it works.

Not alone, but in certain situations it becomes audible. When aligning tracks in order to cancel out parts, even 1 sample misalignment can decide whether it will work. Misalignment creates phaser-like effect, or if stereo separated it breaks the soundstage. In extreme cases, the best spot may even be in between sample and you get better result by upsampling so that you have even better control.

It also worked for me.

Not alone, but in certain situations it becomes audible.

Only if the sounds are “related” such as a stereo file with common “center” information. And playing with the speed/sampling could cause equally-weird results depending on what caused the “problem” in the 1st place.