Can't change pitch, tempo, or speed, nothing works!

So everytime I try to change some values, for example if I want to change the tempo of a clip, I would select everything and then go to the Change Tempo option and use the slider. No matter what I set it to, I always get an error popping up “Validation error. Value not in range: -99,000 to 3000,000.” Nothing ever works, not even if I type a value myself. Now I dont know if this is an issue with Windows 10 or the version of Audacity I’m using (I’ve tried the official and the nightly versions). Even a Google search gave me nothing about validation errors. This is all from a fresh installation by the way, so no other settings in Audacity were changed.

I would select everything

How? You can select an entire song by clicking Stop, and then clicking just above the MUTE button on the left. None of the settings work from Pause. You have to be in Stop.


Yep, I’ve tried that too, I press stop and then options become available but still the same.

What language is Audacity using? When set to English, the error message shows (dot as decimal separator):
Validation error.
Value not in range: -99,000 to 3000.000

please give a step by step example: What track(s) are you selecting, which box are you typing into. exactly what are you typing, what / where are you clicking?

Ok, so I open Audacity, load my .mp3 file, and without hitting play or anything, I go to the Effect menu and go to Change Tempo…

It then has a default value of 0,000. It is already highlighted. Now, when I move the slider down to say, -2,000 I would normally hit Preview. For this particular effect, the ranges seem to be between -99,000 and 3000,000, that’s the error that pops up. I then hit Ok to close the popup.

These are the default settings for the Change Tempo effect in Audacity 2.1.2 with English as the default language. There is not a comma to be seen:

It would appear that you are NOT using Audacity 2.1.2 with English as the default language on your computer. What are you using?

Well here is my screen. Note that I have also checked the language of it under settings and everything is the standard English language

Look, basically everything is stock, downloaded straight from the official website. Nothing has been messed around with. I don’t get what the cause of this is, and so far, no one else seems to either. If this was a well known issue, I’m sure people would quickly make a correction and know what to do straight away, but I get that it needs to be narrowed down first. That’s why I questioned if it was a Windows 10 issue, as I have had Audacity on other versions of Windows in the past, and all have been working great. There have been suggestions of installing additional plugins for Windows 10 but I assume this has nothing to do with the problem at hand, they seem to be about codecs etc.

For a standard English language computer the decimal separator should be a dot.
Audacity decides whether to use a dot or a comma based on the system settings of the computer.
Change Tempo on your machine is showing a comma as the decimal separator.

This article shows how to check the number format:
Is your system configured to use a dot as the decimal separator?

Do you see a comma or a dot as the decimal separator in other effect? (example, the “Amplify” effect)

Does British English or other special purpose English use the comma? Change to British English and see what happens.

Have you done a reinstall using a fresh download and the Reset Preferences option checked? Nowhere in the thread did you explicitly say that.


Reset Preferences won’t help (and it does not change effect registration or effect settings even if it was an effect settings problem).

The answer is to change the Windows numbers formats back to decimal point, or you will only be able to apply effects where all the controls are set to whole number values (which mostly won’t be possible with Change Tempo/Speed/Pitch).

Or if you can understand a non-English language that uses comma separator, change to that language in Audacity’s Interface Preferences.

I think, but have not double-checked yet, that we cannot easily remove this restriction that the decimal separator in Audacity matches the system separator. And we won’t want to remove the validation.


I did everything, even resetting preferences when reinstalling. I have also made absolutely sure everything is set to English (United Kingdom) in my Windows settings, number formats, everything. I now see that Audacity has taken upon this new setting and has changed value separators to dots. Want to know what’s funny. It STILL gives me the same error! Just like my previous screenshots. The commas are now replaced with dots, but it seems to have not changed anything at all. I’m about to throw my laptop out the window lol.

Good, that’s a start.

Do “any” of the built-in effects work as expected?

Try this. Quit Audacity, then open File Explorer or your favourite file manger. Type or paste


into the address bar and hit ENTER on your computer keyboard.

In the folder that appears, delete the “pluginsettings.cfg” file.

If that does not help please tell us what language Windows 10 is installed with.


Ok so none of the suggestions helped. My Windows is installed as English (United States) origianally, but I thoroughly went through every setting to ensure that it became English (United Kingdom). What Windows builds are you guys working on? Can you give me a specific set up example whereby these effects will work? Can you also replicate a full installation on your end so that I may try to emulate it on mine?

And by the way, not sure how it helps, but upon first noticing this issue and a few attempts to try to rectify it myself, I went ahead and installed the LADSPA plug-ins. And to be honest, as I suspected, it didn’t work.

I’ve tried with Audacity 2.1.2 and 2.1.3-alpha from official sources

Here are my settings when I open intl.cpl:
Windows settings could be messed up. You could reset your PC.

Or if it worked before and the problem has only just happened, try a System Restore back to a date when it worked, if you have System Restore enabled.


Brilliant, I’ve adjusted it exactly according to your settings and it worked! Sorry for the headache guys. Case closed, you can stop the thread now lol.

Thanks for letting us know.
Out of interest, did you notice which settings were different on your computer from the settings in Gale’s post?

Windows 10 allows apostrophe to be set as decimal separator. I tried that out, but it does not create a problem in Audacity running in System, English or locales where comma is the separator.