Can't apply any effect, Value not in range
Windows 7-64bit
Audacity 2.4.2

I cannot do any effect, as shown on the picture in link. All values are within bounds, but program says they are not.
I surely have the same problem as this person because I have Czech keyboard which also uses comma as default decimal separator.

I tried
-going into keyboard language settings and changing it to US, restarted PC
-try manually changing the decimal separator to dot in number formats and currencies and restarting pc

idk what to do anymore and I would prefer not to use other program.

Open the “Nyquist Prompt” effect (in the “Tools” menu).
Copy and paste this code into the Nyquist Prompt, then click the “Debug” button:

;version 4

What happens?

Hello, thanks for helping me, steve
When I copy the code into nyquist prompt and press debug, it shows this:


That means that the decimal separator is the “dot” character.

Are you using a Czech version of Windows?
Is Czech your primary language?

No, all windows elements are in english except the keyboard which is a czech keyboard, because I live here, but eng is my primary language.

It’s not necessary to key-in a decimal point into that particular effect …

can use the decimal point provided.png
Either use the slider, or just type-in numerals, using the decimal-point generated in the fields.

Even just selecting an effect and clicking Apply/OK or using slider (not typing anything into any field) will yield the value Not in range error

If you then launch the same effect again and (without changing anything) apply again, does the same error message appear ?

Yes, same error. Even when I’m not changing anything at all in the effect window and just apply it, error appears.

I don’t have Windows 7 (it is now obsolete), but I think the problem is that you have conflicting settings regarding what the decimal separator is. You need to go through the Windows settings and ensure that the decimal separator is either set as a comma in all places, or a dot in all places. Check that in the “Regional and Language Options” that the “locale” (“regional setting”) is consistent with the number format settings.

Thanks for your help, but thats a little too much when I only want to edit a couple of files. Ill use something else and come back to Audacity after I upgrade to Win10

Hi, I’ve been having the same problem. I also live in the Czech Republic. I have a Windows 10 and the error still occurs. I also tried to change the preferences to “local settings” in audacity, but the program still uses commas instead of decimals. It’s truly infuriating.

So Windows keeps moving things around…

I think steve means:

Settings (or Control Panel) > Time/Clock/Language and Region > Region (Change date, time, or number formats) > (Region Formats) Additional Settings > Decimal Settings

Also, see this thread: windows 8 - Dot instead of comma on numerical keyboard - Super User