Can't adjust input level for pulse monitor in Audacity

Audacity HEAD, Ubuntu 13.10, 1 GB RAM, 1 GHz netbook.

Reading it says I should be able to “begin playback in the application that you wish to record and set the recording level in Audacity.”

However I can only adjust the input level on the Recording tab of Pulse Audio Volume Control. The Audacity input slider is always greyed out when pulse or its aliases are selected as input, and I think this has been true for a long time. Al Dimond always regarded it as a bug when the Audacity input slider was enabled for pulse input because all it could do was apply gain after the input Audacity was receiving.

Have you (Steve) got the Audacity input slider enabled for pulse in any circumstances?


Same here.

I’ve just tested with Audacity 1.3.10 and the input slider is not greyed out, but the slider has no effect when using Pulse.

I assume that when that guide was written that the Audacity slider did work. Notice that in the accompanying screen capture PulseAudio Volume Control does not have a recording level slider.

I’ve updated the image and text:

By the way, it took a bit of massaging to get 1.3.10 to build.

./configure --with-portmixer="local" -with-sbsms="local" --without-ffmpeg