Can't add libraries on Ubuntu

I downloaded and compiled a plugin (talentedhack) on Ubuntu. I got the .so file, but can’t find anyway to import it into Audacity. The web says to go to


Problem is that that option isn’t there on my Ubuntu Audacity. I assume it must be on other systems, but not mine.

Please state which version of Ubuntu you are using and the exact three-section version number of Audacity from Help > About Audacity…

Well I was on Lubuntu, but have now installed Ubuntu-Studio and am running Audacity 2.1.2 now. Does that help?

In Audacity 2.1.2 there is a “plug-in manager” for enabling/disabling effects. see:

I know how to use the plugin manager, but the plugin I am using is LV2. I put it in a directory with a bunch of other LV2 files, and ran another audio program. The other audio program was called ‘Muse’, and it read the LV2 plugins automatically from the directory. I would much rather use audacity however. How ca it n I install a LV2 plugin in Audacity? In the settings window of Audacity it shows that LV2 plugins are enabled.
Please help!

Okay, so I set the lv2 plugin path, and now all of the .lv2 plugins are showing up. Most seem to work, but the one I want: talentedhack.lv2 doesn’t appear in the effects menu after I enable it. In fact after I enable it, it will change itself back to “new”. Any more ideas?

Does it give any clues in “Help > Show Log”?
Have you tried “Autotalent”? Last time I tried, that worked in Audacity.

Nothing shows up in the help logs. AutoTalent seems to work fine, but I haven’t been able to get it to work practically for my audio. That’s why i want to use this other plugin. They say it is better than AutoTalent, and built off of its code.

To make full use of Tallenthack you’d really need to use a different host program because Audacity does not support the MIDI features.