Cannot upgrade from 2.1.2

Windows 10 home, Audacity 2.1.2, Ubuntu 16.04 LTS.

First problem I had was when I downloaded Audacity from the site. I tried to run the installer for the file type “AppImage” but got the message “Archive type not supported”. I then did a CLI to install and v. 2.1.2 downloaded and installed ok. Then I noted that under “Effect” it shows the option for “equalization” [not the newer curve type] which I guess is due to using 2.1.2, it being an earlier version. But, almost all of the options under “effect” are greyed out, including “equalization”.

My questions are:

  1. How do I get the latest version - 3.1.3 - installed?

  2. If I cannot install v. 3.1.3 on Ubuntu 16.04, how do I get they equalizer and other greyed out option to function?

    Moderator note: no need to shout. I resized this to normal size.

The Appimage is not a .deb, you don’t need to install it. You just need to chmod +x it and then you can run it by double-clicking it.

That said: I’m not sure if 16.04 is still supported by us, or by AppImages in general. We generally check against 20.04.

An appimage is not an installer file, it’s a prebuilt executable. You just need to mark it as executable (this is not done by default for downloads, for security reasons), then run it.

eta: snap :slight_smile:

Good point re 16.04 - I think I tried running Audacity 3 on an old Kubuntu 16.04 image I have and it failed with the required levels of GLIBC not being available. You may have to stick with Audacity 2. If you can’t upgrade your OS, you might at least be able to run a later version (2.4.2 is the last I think) of Audacity 2.