Cannot Set Preference to Mono

In Preferences, if I setup by default (i.e. in Stereo) then fine. However, if I try to set to Mono I get the following error message:

“Error while opening Sound Device. Please check the Recording Device settings and the project sample rate”.

I only wish to record in Mono as this is only used for recording “spoken word”, not music or songs.

Can anyone help? (I went through FAQ but the closest I could see were topics around “trying to Import to/Export from Mono”)

I get this problem on Windows 10 and also had it on Windows 8.1. Also, I installed the .exe, not the .zip version of Audacity.

Many thanks in anticipation.


Geoff H.

Which version number for Audacity? (look in “Help > About Audacity”).

What are you recording with ? (example: "a Shure SM56 microphone plugged into the left input of an M-Audio mobile pre USB, which is plugged into a USB socket on my laptop.)

What settings do you have selected in the device toolbar?

Steve, many thanks for a speedy response.
In reply to your questions…

Audacity 2.1.0

I wish to record directly from “PC Sounds”, e.g. via webpages - not particularly looking to record from CD/DVD nor via USB

Having said this, I have not got that far. As I mentioned before, the problem is in trying Setup in Preferences so, with this in mind the settings in “Device Toolbar” are:

  1. MME

  2. Windows Direct Sound
    … neither of these offer any devices

  3. Windows WASAPI
    … this offers "Speakers (Realtek High Definition) Loop and “Realtek Digital Output”. On both of these, when I try to select Mono it gives the error message I reported in my previous message.
    Stereo seems to work.

Hope this helps.


Geoff H.

When using WASAPI, Audacity’s recording settings must match the device that you are recording from. This is because WASAPI gives a more direct connection between the device and the recording application, missing out format conversion.
The “Speakers (Realtek High Definition) Loopback” device is stereo, so Audacity must be set to record in stereo.
If you require a mono recording, record it as stereo, then convert the stereo track to mono.

There are two ways to convert a stereo track to mono.
Either you can “mix down” the two channels to a single mono track using “Tracks menu > Stereo Track to Mono” (use this if the stereo track has good audio in both channels), or, split the stereo track into two mono tracks, and delete the track that you don’t want. See here for how to split a stereo track to mono:

The problem recording in mono is mentioned in the Release Notes in a rather long section about WASAPI:

I don’t receive that particular issue recording from WASAPI in mono on Windows 10 or 8.1, even though my playback devices only have stereo choices in “Default Format” in Windows Sound.

It could depend on your particular playback device, or it could be that making the playback device’s Default Format sample rate the same as the Audacity project rate, or enabling the “Exclusive Mode” boxes in Windows Sound will make mono recording less error prone.

Generally, WASAPI behaves better if Audacity project rate is 44100 Hz and both Exclusive Mode boxes for the playback device are on (checked). Exclusive Mode on “should” mean that the Default Format rate is ignored by Audacity and it just receives audio at the rate specified in the project rate, but that may not always be the case (another “bug”).

Restart Audacity after changing any settings in Windows Sound.



Many/many thanks for great support, it is much appreciated.

I shall try what you say and report back.

Best Regards.

Geoff H.