Cannot save Project, Exporting Only last Few Minutes of File

Hi, I run a Podcast, and I have run into this problem exporting the files. This has only happened recently, after I had to clean out a virus, before that I have exported literally hundreds of episodes of all length with no problem in any format. Now, when I try to export into wav, mp3, or anything it only exports the last couple of minutes of the file. When I try to save the project uncompressed it gives me the old “Is unable to save file, perhaps drive x is not writable or full” no matter that the drive is not full, and I have full permissions. When I try to save a compressed version, I obviously get the same problem as when I try to export. I am running a Windows 7 home premium ASUS with 6gb ram and over 250 g free memory, I have audacity version 2.0.2. I can’t see that it matters, but I am running a blue yeti through a usb, and have not changed my setup since previously successful exports and recording sessions. I feel like this is a simple misunderstanding on my part, or my computer is hosed somehow, the only source of stress on this is that I cannot save or do anything with the show that I have recorded and currently have open on audacity (where it plays back fine). This makes restarting, or doing anything at all really, dicey at best. So any steps that don’t involve me losing this episode would be helpful, plus I already lost a whole episode (with a priest!) to this same problem, and since I restarted and ran a disk cleanup/antivirus in between that l lost episode and this potentially lost episode I don’t think that will be the solution anyways. Thanks for any help any one can give!

The normal possibilities are you really did run out of drive space, you used bad characters in the filename, you have permissions issues, etc. But what’s the possibility you have your virus software cranked up to Instant Violent Death and it’s preventing Audacity from writing the files?

Take the machine off-line. Disable the virus software and see if that helps.

How long is/are the shows?


Thanks for getting back to me, I don’t see how I could have run out of disk space, I’m pretty good about transfering the shows the backup so I have 250 gig free, I am the admin for the machine, I didn’t use any bad file names, and I tried disabling the anti virus and it didn’t do anything. That also doesn’t really explain why the file would be exported as silence until the last few minutes, it might explain the can’t save issue so I’ll double check that. And the shows are usually an hour, this one is 33 minutes.

The current version of Audacity is 2.0.6, available here:
There have been lots of bug fixes since 2.0.2, so definitely worth updating (even if it does not solve this specific problem).

Note that the maximum valid size for a WAV file is 4 GB. You may sometimes get away with larger than 4 GB if you are on a 64 bit operating system, but it is not strictly a valid WAV file (see:

What happens - do you get a full length file but silence until the last couple of minutes, or the exported length is only a couple of minutes?

Is it a multi-track project and have you muted any of the tracks? Muted tracks are not exported.

Have you tried rebooting?


It’s the first, I get the file length of appropriate size but only silence until the last few minutes. It’s a one track mix, I recorded in mono. I had tried rebooting before and no luck, I haven’t this time since I will lose this show. And I am on a 64 bit, I understand the wav problem with it but I just have never had this problem before.

Is the last few minutes louder than the rest? Did you turn down the -…+ gain slider on the track by mistake?

Does it make any difference if you double-click in the track to select all of it, then Tracks > Mix and Render before export? It should not make any difference but you are using an old version of Audacity.

If you can hear the earlier part of the show normally in Audacity, then try playing it and recording it. You can do that in Audacity if you turn on Transport > Overdub and choose the Stereo Mix input if you have that. If you don’t see stereo mix, see if you can enable it in Windows Sound - see

Otherwise record with another app like SoundLeech or the demo version of TotalRecorder:


The last few minutes are the only noise on the entire file that I try to export, the rest is no data silence. I did not mess with the gain bar, the single track has recorded perfectly. The playback is fine, it is an export or save problem. I can’t stress how many shows I have recorded using this setup without any problems, well over 200 shows counting all. If this is something I can’t fix without deleting this show and reinstalling a new version of audacity so be it, but I won’t do that until I have to. And as for another sound recorder program, that seems a little un related. Thanks everyone so far for the help, still ned a bit more!

I think the idea of the second sound program is to provide a safety copy of the show so you won’t have to produce it again. Since it plays OK, telling the computer to record Computer Playback (Stereo Mix) will give you a new digital copy of the show. It may still go into the mud since we have no good idea why it’s failing.


Did you try Tracks > Mix and Render as suggested?

If so there are no other options open to you that I can think of. If you can actually play the show correctly in Audacity, playing the show in Audacity and recording the playback (probably safest in another app) is the only thing that is going to save the show for you.

You can even use Windows Sound Recorder if you don’t mind losing a little quality:
Record audio with Sound Recorder.


Well, I tried tracks mix and render like you said, and it did to the raw file what it was doing to the export. So I no longer have to worry about this show, it’s gone. I guess I’ll try to reinstall a new version, but honestly if I have to worry about this happening at some point in the future I can’t think of a reason to stay with audacity. It has worked for years with great results, but the risk is too high. Not to mention that it seems that most people here really didn’t have any ideas beyond the most basic stuff that didn’t apply to my problem (exception being the ideas about the antivirus, and the idea to record the file with another program without export). Not blaming anyone, it’s not the current build so not as much attention will be paid to my problem. The only thing I’ll say comes close to a fix, if anyone else on the Internet has this problem and wants to fix it, is the great suggestion to simply record the file playing. It’s a Huge lowering of quality, but if I had done that first at least I would have something to show for this whole nasty experience. If anyone cares I’ll post if the reinstall works.

I would be far more concerned if it was a common problem and we all jumped up and said “oh yes, we know what that is”.
Contrary to that, it appears to be a problem unique to your machine, and you told us “This has only happened recently, after I had to clean out a virus”. The most likely explanation that comes to my mind is that the virus did some damage to your system (you say that Audacity has worked flawlessly for years before this event), and that although you have removed the virus, some of the damage caused by the virus remains.

Having a computer infected with a virus is a nasty business. Although there are many anti-virus products available that are able to remove most viruses, they do not repair whatever damage has been caused during the infected period before removal. Unfortunately it is often the case that the only way to fully repair the system after a virus infection is a clean install of the operating system.

I would be far more concerned if it was a common problem and we all jumped up and said “oh yes, we know what that is”.
Contrary to that, it appears to be a problem unique to your machine, and you told us “This has only happened recently, after I had to clean out a virus”.

I agree completely, I think since it is a unique problem I was looking for a work around solution, not a code or bug fix. And the lack of concern for this type of problem is probably why I don’t have that show anymore, I’m not blaming anyone or trying to be a jerk, but the odds are Someone Somewhere will have this problem again. They are better off just taking a big hit in quality and not bothering with a workaround using audacity, I feel.

Does Edit > Undo Mix and Render get the show back?

It sounds to me like the data for all the show except the end is damaged.

Are you sure that part of the show isn’t a WAV or AIFF file that has gone missing?

It’s not a huge lowering of quality. An unwanted conversion through analogue back to digital, but you can turn off system sounds to make sure they don’t get recorded.


Sounds like the same problem I’ve had for the past two weeks. I observe the sound waves at the start of the recording and I continue to see the sound waves all through the sermon. When I stop recording (about 30 minutes) I only have sound waves for about the last 10 minutes. From the beginning to the where the last 10 minutes starts the sound wave line is now flat. From looking at the log file it appears that the the small files that Audacity automatically saves as the recording progresses are now missing except for the last 10 minutes. Don’t know if this is a Windows 7 problem or an Audacity (2.0.5) problem. I’ve done over 100 recordings and not had this problem before.

It is better to start a new topic even if the problem seems similar to you. If the problem is not the same then posting here muddies this topic. You can always give a link in your new topic to the topic you want to reference.

Is it a problem that explicitly occurs when you press Stop, or has the problem already happened? While you are still recording you can do View > Zoom Out a few times to see the start of the recording.

It is probably neither.

Look at Edit > Preferences… then “Directories” at where your Audacity temporary directory is and how much space is on the drive. Each 30 minute recording takes about 600 MB by default (if stereo) and each edit of that complete recording takes another 600 MB.

Norton or some other cleanup tool you just installed could be interfering, thinking you want to clean up unwanted files. If you save a project to your Desktop before recording it may discourage a cleanup tool from interfering with the recording.

The drive you are writing to could also be failing. See How to See if Your Hard Drive is Dying with S.M.A.R.T. for how to check that.