Cannot Record

I’m running Windows 10 with Audacity 2.1.2.

Sound card is Creative Titanium Xfi and using Bose USB speakers.

I cannot record what is playing through the speakers.

On the drop down menus, I have “MME”, “What U Hear”, “2 Stereo”, and “Speakers (USB)” selected.

I even tried running Audacity In Windows 7 Compatibility mode.


I cannot record any sounds from my Windows 10 machine.

Settings: Windows WASAPI, What U hear Creative, Stereo, USB Speakers (Bose)

See is there’s anything in here:


I have tried all of these suggestions. No luck. I was able to record into Audacity using an external (non-USB) Microphone.

Use the “WASAPI loopback” method described here:

I merged your duplicate topics. Please stay in this topic now.

You don’t need what U hear Creative. Try changing the recording device to “USB Speakers (Bose) (loopback)”.


I tried all the new suggestions. Using the Bose speakers (loopback) for the recording device produced an error message.

Make sure Audacity is set to record in stereo. Restart Audacity.

Make sure you are playing the audio on the Bose speakers. This probably means you will have to set the Bose as default playback device in Windows Sound. Right-click over the speaker icon by the system clock, then choose “Playback devices”. Now you are in the Playback tab of Windows Sound. If Bose is not shown as Default Device, right-click it and make it so.

If you still get an error, set Audacity project rate (bottom left) to 44100 Hz. Go back to the Playback tab of Windows Sound. Right-click over the Bose then choose “Properties”. Then click the “Advanced” tab. Under “Default Format” choose a 44100 Hz option and uncheck both “Exclusive Mode” boxes.

Restart Audacity. Play the audio you want to record before pressing Record in Audacity.


Still no luck. I was unable to change the speaker playback from 16 bit, 48000 Hz. There are no other options available.

Then please try changing Audacity project rate to 48000 Hz, and try unchecking both Exclusive Mode boxes in the playback properties of the Bose speakers. Restart Audacity after any changes in Windows Sound.

Please note for most cases you can download online content rather than record it. Please use your favourite search engine to find out how. Obviously you will require content holders’ permission either to download or record.


This is very disappointing. I was able to use Audacity when this was a Windows 7 machine. Now that it is Windows 10, the software is unusable.

Have you done the following yet?

If not, please do so.

Do your Bose speakers actually support Windows 10? Do the speakers require you to download special drivers for Windows 10? Please investigate that by going to the Bose site.

If I have permission to record some online content, I never actually record it. I download it instead, even though I could record it. Have you investigated downloading the content?

If you must record rather than download and you are still stuck, please attach all your devices, launch or restart Audacity then open Help > Audio Device Info… and attach the file it saves. Please see here for how to attach files:


I was able to install and use Audacity on another Windows 10 machine that I own. This unit does not have a Creative sound card. I believe the Creative card is incompatible with audacity.

I believe the Creative card is incompatible with audacity.

More likely the card’s drivers are incompatible with Windows. If your device and software support doesn’t say in clear English “Windows 10,” whether or not it works is a gamble. Windows 10 requires specific, intentional drivers and interface software. Having it work in an earlier version of Windows doesn’t do anything for you.


You are not playing the sound on the SoundBlaster X-Fi Titanium. You are playing the sound on the Bose USB speakers, because the USB speakers are a separate sound device.

If you want to use the Bose speakers you cannot even use the Sound Blaster, so why not uninstall it?

If you do want to use the that X-Fi Titanium then it definitely supports Windows 10. So if you have the drivers in that link, and select the following in Audacity

Host: Windows WASAPI
Recording Device: Bose USB (loopback)
Playback Device: Bose USB

and set Audacity project rate to 48000 Hz, it “should” work.

If you don’t have the correct X-Fi drivers in that link then yes it is possible it could interfere with Bose in some obscure way.