Cannot record

I have Ubuntu 11.10 and Audacity ® 2.0.1-alpha-Apr 10 2012. I cannot get Audacity to record through line-in at all. When I click on the output meter, I get nothing. If I start recording, I get nothing. I have Preference set as they were when I upgraded from 1.3.13:

Host = ALSA (only choice) using Port Audio V19 (built Jul 27 2011 11:52:20)
Playback Device = default
Recording Device = default:Line in:0
Recording Channels = 2 (Stereo) - all the others except 1 (Mono) have no description

My sound card is a Creative Labs Soundblaster Audigy SE.

Everything worked prior to this upgrade. If I check things with Pulse Volume Control, the Input Devices tab shows Port as Analog Microphone. If I change this to anything else (Analog Input/Line-in/Line-in for example), it goes back to Analog Microphone when I change focus to the Audacity window (or any other window, for that matter). I have tried every different combination I can for the input device, output device, and channels. Any suggestions will be greatly appreciated.

What are the options in the “Recording Device” drop down menu?

How / where are you changing that?