Cannot Record While Using Line 6 Tone Port and Microphone

I’m using Audacity 2.0.5 and I am attempting to record music. I have a Line 6 Tone Port UX2 with one microphone plugged in. My choices in the drop-down menus at the top of the screen are as follows: for the first menu I have the choice of: MME, Windows Direct Sound, and Windows WASAPI. The speakers menu: Primary Sound Driver, Speakers (Line 6 Tone Port UX2), Communications Headphones, and Speakers and Headphones. The microphone menu: Primary Sound Capture Driver, Internal Mic, Headset Mic, Digital Audio Interface (Line 6 Tone Port UX2). The fourth menu: Mono and Stereo.

When I hit record it looks as if it is recording but the microphone is not picking up any sound. I have turned on, plugged in, and double checked my microphone and my Line 6 audio interface.

I do not know what exactly the problem is to fix, can anyone help?

Basics first. Have you tried selecting the UX2 as input device in Device Toolbar ? Have you tried turning up the input volume slider in Audacity?

Is there any sound from your headphones plugged into UX2? Have you read the UX2 manual?