Cannot Record, though Settings Not Changed


Using Audacity 2.1.2 on Windows 7

I am trying to add new tracks to a basic recording, but I keep getting this error, despite being able to record audio an hour ago, using the same settings:

How do I fix this please?


Describe what you’re recording and how. That error can be either record or playback because Audacity can be configured to play the work as you’re recording it.

If you’re really trying to record a USB microphone, please note Audacity checks for new devices when it starts. If you unplug your mic and then plug it back in again—or you have a loose USB plug, the microphone will vanish and could cause that error.


Rebooting, or restarting Audacity might help. Some other application could have changed settings in Windows Sound.



Thanks for your replies.

I am using a headset with pink and green plugs, not USB. I am recording my own voice and my own percussion onto a basic song I previously made.

Now I tried recording after the PC has been off overnight, and it lets me record for half a second then stopped. The same thing happened a second time. Now the same error as yesterday is showing.

UPDATE: Wiggled the wire and it works… for now!
I guess I need to buy a new mic or headset

thanks a lot