Cannot Record Streaming Audio in 2.0.5

Hi Everyone,
I am sorry to post about a subject that must have been done to death, but I have spent the last 2 hours on the Internet, Youtube, and this forum Trying to find a solution to a problem that I have with not being able to record streaming audio using Audacity 2.0.5 , on Win XP Professional.

I was using 2.0.4, but then thought that I would uninstall the Program and install the latest XP version, just to see if that might fix the problem, but unfortunately it has not done so.

I downloaded the .exe file, not the .zip file, for 2.0.5.

It seems to me that part of my problem might be that I cannot access the ‘mixer’ option in the Device toolbar, but I might be wrong about this.

Let me first be clear about my setup, in terms of what displays in Audacity.

  1. ‘Host’ dropdown - here I have the choice of either ‘MME’ (which is the default), or ‘Windows DirectSound’
  2. ‘Output Device’ drop-down – here I have the choice of either ‘Microsoft Sound Mapper’, or’SigmaTel Audio’ (i.e., my soundcard)– The latter is chosen by default.
  3. ‘Input Device’ drop-down– here I have the choice of ‘Microsoft Sound Mapper-Input’, or ‘SigmaTel Audio: Line In’, or ‘SigmaTel Audio: Microphone’ – the latter is chosen by default
  4. ‘Input Channels’ drop-down – here I have the choice of ‘1 (Mono) Input Channel’, or ‘2 (Stereo) Input Channels’ – the latter is chosen by default

I have experimented with every potential combination of the above while playing different streaming audio files in order to try to record into audacity, and have been unsuccessful.

I have also tried looking for a ‘Mixer’ section under the ‘Adjust Audio Properties’ Option that I get when I right-click on the speaker icon in the lower right-hand corner of the screen system tray, but have not come across anything which approximates exactly some of the choices that I’ve seen in some of the videos and tutorials that I have looked at on the Internet. [The default device under both the ‘Sound recording’ and ‘Sound playback’ tab when I go to one section of the Audio Properties, is ‘SigmaTel Audio’, i.e., my sound card – and this is the only choice that I have under the Playback and Recording tabs - should I have other choices here? It is possible to select different speaker playback options – right now I have ‘Laptop Stereo Speakers’ selected, and there are many other options].

My understanding is that if I were to see a ‘mixer’ option, should choose it, and that would provide me with a ‘mature’ option in the ‘Input Channels’ drop-down box on the Device toolbar.

Even if this is not the problem, I cannot figure out why I am unable to record streaming audio using audacity, and would very much appreciate some help.

Many thanks,


Interesting you can’t get it to work in XP. Windows XP is usually pretty good about being able to manage the pathways and do self-recording. It hadn’t learned any evil habits yet.

You never said in specific English that you read the wiki on self recording.


Hi Koz,
Thanks for the reply.

Yes, I had read the Wiki (to Forum Admins. - maybe it would be a good idea to include reading the Wiki in the red text at the top of the page - I read that, and mentioned everytying included there).

Any addiitonal ideas?

I am completely flumoxed by this.


Have a look at Sound Problems in Microsoft Windows

Links to the Wiki Tips and Tutorials are in the blue banner at the top of every page.

It’s a recording (input) device you need, usually called “What U Hear” or “stereo mix” or “Wave Out”.

Are you sure you read the Windows details for recording computer playback: Audacity Manual ?

Did you follow what it says there to make sure you have enabled all the input devices?

Windows XP or earlier

  1. Right-click over the Speaker icon by the system clock then choose Adjust Audio Properties.
  2. In “Sounds and Audio Devices Properties” or similar, click on the Audio tab, then in the Sound recording panel, select the “Default device” you are trying to record from (this will probably be the name of your built-in sound device).
  3. Click the Volume button.
  4. If you can see a stereo mix or similar option, try clicking in its box to select it.
  5. Otherwise, choose Options then Properties.
  6. In the window that appears, click the “Recording” radio button, then in “Show the following volume controls”, click in the box for stereo mix or similar, then “OK”.

There are pictures here: Missing features - Audacity Support .

You have a Sigmatel line-in, so you can always run a cable from audio out (green) to line-in (blue) and set Audacity to record from line-in.

What is the make and model number of the computer? If it is a branded computer does it have the latest Windows XP drivers for that model obtained from the computer manufacturer’s web site? Correct drivers “might” give you a new input for recording computer playback. See: Missing features - Audacity Support .