cannot record second track when overdub checked

Windows 10. Audacity 2.3.3. m-audio usb recording device. I want to be able to hear my first track whilst recording a second one but the following has suddenly started happening. First track records, no problem, but I cannot hear the first track whilst recording the second. Try to record the second track and the cursor just sits there and doesn’t move.

So I unchecked the overdub and then hit record, the second track recorded as normal, but I can’t hear the first track? I’m recording acoustic guitar on the first and want to lay vocals over it on the second but I want to listen to the first track whilst doing this - just as I’ve always done without issue.

Everything checks out fine with my windows soundcard settings, drivers etc, microphone privacy settings ok, record on new track is checked, my M Audio usb device is recognised by Audacity and also Windows as the default recording/listening device, NME audio host selected - I have tried them all but no difference, in fact my settings haven’t changed at all and everything has worked fine for the past 4 years.

Everything works with Ableton, but I use Audacity instead because it’s more user friendly for me and does what I need, until now. Never had this issue before. Could it be a Windows update problem?

I have replied here: