Cannot record 210709

Hello Audacity forum,

Using Windows 10 and Audacity 3.

Also using a system for recording thru a microphone:
a level booster called Audio Buddy receives signal from
Shure SM58 and sends to M-Audio M-Track which goes
to USB input at laptop.

This has worked many times for years before. Recently my wife
used my laptop to connect audio/video from computer
to watch program on TV.

AudioBuddy and the M-Track (M-Audio USB device) devices show sound levels
when mic is tapped.

At Control Panel > Hardware and Sound > Change System Sounds
there is a green check box at Input M-Track and a sound level
bar that reacts when mic is tapped.

At Audacity:
Track, add new Mono Track
Input: M-Track
Mono recording Channel
Speakers Real Tek Audio
Audio Host: MME, Windows DirectSound, Windows WASAPI
All three tried with no discernable difference

It is noticed that the inverted triangle above the vertical
line that shows the recoding is red. Don’t think it was red
before but not sure.

Before when the red circle, record button, was tapped
the waveform of the recorded sound would appear in the
track ribbon. Now there is a flat line and nothing is being

Because this has worked for years before the spouse
fiddled with it it is conjectured that some change
made at that time and is the culprit. But I have searched for
hours and can’ figure it out.

Could be the M Audio driver. Will uninstall and reinstall
after that I am stumped.


Allen Pitts, Dallas TX

What does “210709” have to do with this? What is that?

I think it is the date of posting of this thread (2021-07-09)

You can check that Audacity’s sample rate and your track rate agree with the Windows recording and playback default sample rate of your M-Track.

And you have tried rebooting?