Cannot read LOF files with International Characters in LOF files & filenames

I’ve been using Audacity for a few years, currently I use Audacity 3.1.3 and I’ve had this issue many times on many versions where Audacity cannot read an LOF file if there is an international character in a filename such as “úéåöä…etc…”

It’s easy these days on many O.S’s to have filenames with international characters.

Editing the file to replace the “offending” characters with one from the standard [a…z][A…Z][0…9] character set in a text editor and then changing the filename to suit has gotten me out of trouble each time but as part of an international choir I can’t stop the users using normal spelling of their names re-creating the problem every time I make a recording.

I wonder if it is possible that the dev’s could have a look at this to see if a wider character range can be accepted please.

Works for me with Audacity 3.1.3
(It was fixed 19 Oct 2021)

Supported character encodings are:
UTF-8 (with and without BOM)
UTF-16 (with and without BOM)

Thanks for the reply Steve, I don’t know what encoding this is, but it’s an example of an LOF that won’t open without editing.
Jam-20220319-230149532.lof.txt (672 Bytes)

That works for me after removing “.txt” from the end of the file name.

Full Window000.png

Thanks again Steve,

I hope I’m not missing something stupid but if so at least it will be a resolution! This is still not working for me, I definitely have Version 3.1.3 on Win 10 with i7 16GB Ram.

I’ve have attached the Error and Build info as screenshots.
Error Importing.png
I’ve gone back over this and made the following changes and observations.

I reduced the size of the WAV files to a few seconds and made a copy without the “ú”
I edited the LOF so there is only the one file to open and again made a copy with “u” instead of the “ú”
A Hex dump of the “error” LOF file has 6 bytes for “Jesús” “0x4A6573C3BA73” but the other working file has only 5 for Jesus “0x4A65737573”

I attach a zip file of both versions, the only difference is the ú/u

Best Regards
Jam-20220319-230149532(1fileerr).zip (567 KB)
Jam-20220319-230149532(1fileok).zip (567 KB)

This is very helpful. It explains why you are seeing the problem.

The lof file is encoded as “UTF-16 Little Endian”.
In a Hex dump, the ú character is “C3BA”

The WAV file name is:


The hex value of the character after “Jes” is C2A3.

Thus the name of the in the LOF and the name of the actual file don’t match, so the file is not found.

How / what app did you use to name the WAV file?
How / what app did you use to write the LOF file?

Does this version work for you? (538 KB)

Thanks Steve,

No that didn’t work… The recordings were made on Ubuntu 18.04 with software called Jamulus

It’s open source and available on github at
I think all the recording is done by this file… but I’m not C++ proficient to tell where might be the issue.

I’ll have to check what version I have on the server but I don’t think there have been many changes in this section of the code.

Thanks again, it looks like it might be Jamulus could be the troublemaker here!!!

You mean that the “” doesn’t work? :astonished:

I’ve finally been able to test on Windows, and you’re absolutely right - it fails with Audacity 3.1.3.
The good new is that it works with Audacity 3.2.0 alpha, and 3.2.0 is due to be released fairly soon (the last I heard was: “Q2 seems likely”).

Sadly no, the didn’t work.

I’ve also tried a few alternatives (attached…) which also didn’t work… by using the alt+key combination to enter the characters into the lof file úá and even entering possible hex values from charmap. I’m using Hex Workshop (1.66 MB)

Ahh excellent :slight_smile: That’s great news thank you. Only one final question so…

…what’s with the “Paris Paris” morse code in the wav files :smiley: ?


I’ve been working on a morse code encoder/decoder plug-in.
“Paris” is commonly used as a standard length word for calculating morse code speed. That file was just a test file that was close at hand.

IIRC, that comment was made regarding the beta release, which could push the final release another month or even longer. :wink: