Cannot overdub, getting latency error

Ok, so I’ve been googling and troubleshooting for two days now. Every time I import an audio track and then try to overdub/record on another track (playing guitar with a backing track, specifically) I get this error -

Message from Audacity : Latency Correction setting has caused the recorded audio to be hidden before zero.
Audacity has brought it back to start at zero.
You may have to use the Time Shift Tool (<—> or F5) to drag the track to the right place.

Audacity version 2.2.0
Windows 10 Pro
USB interface is Behringer UMC204HD

When I plug everything into my Macbook Pro and reproduce, it works flawlessly with identical settings to my Windows machine, so I know the interface is functioning perfectly. I can record normally with Windows, just can’t overdub without the above error.


The error message is not obvious, but basically it means that recording has stalled.
As you say this happens (only?) when overdubbing, that indicates that the problem occurs (only) when the device is asked to play and record simultaneously (duplex).
I think the most likely reason that this might happen, is if the device is being asked to operate at two different sample rates simultaneously.

Check the UMC204HD settings in the Windows Sound Control Panel and look for the sample rate settings. Set them to match the “Project Rate” that you are using in Audacity (usually 44100 - look in the lower left corner of the main Audacity window).

The rates are identical in the control panel and in Audacity.

aaaahahaha got it!

You were dead right - I only checked the recording device. On a hunch I checked the playback for my USB interface and it was set to one step higher than the recording interface.

Something that never came up in my searches was to check BOTH playback and recording interfaces on my USB interface.

Please mark this as solved, hopefully this helps someone else. Thanks!

Bah, it works once, but now after I’ve done ONE recording, if I try to record another track I get the same error. Very strange, closing and restarting Audacity lets it record, but only once. Then it tosses the same error. I can keep closing and reopening it, but I don’t think that’s what it’s supposed to do lol.


As an experiment, try setting them all to 48000 (playback and record in the control panel, and the Audacity project rate).

At this point I’m just shaking my head. No change in config, and it works as it should.

I’m gonna just be happy it works at this point lol

No change in config, and it works as it should.

That means it’s waiting for the worst possible time to fail.

There is a technique to find problems like this. You stress the machine and cause it to fail. Every so often in a troubleshooting forum thread, I’ll ask someone if they can make the problem worse. Do naughty things and see if you get the expected failure.

Either direction is useful.