Cannot Import Any Longer to Audacity 2.0.5

I don’t use Audacity every day, so I can’t identify exactly when my problem began, but I can no longer import audio to Audacity. Let me clarify: I’ve tried the click-and-drag method from Windows Explorer, and I’ve also tried the method using File > Import > Audio. I’ve tried to import MP3 and WAV files, but neither file type works. Also note: As I try to import, a track of the appropriate time-length is created, but there’s no audio on it. To be sure, I played-back these blank-looking tracks and no sound is produced.

Re-installing. First I tried to simply re-install over the existing installation, but the problem persisted. De-installing (without removing add-ons, etc) and re-installing didn’t fix it, either. Thinking it might be a system-wide problem, I tested another audio editor program I have (and never use) – Sony Acid Music Studio – and there doesn’t seem to be a problem there.

A Big Clue, Perhaps. I opened the last Audacity project I created (15 December 2013), which opened fine. I could also export MP3 and WAV files from that project. THIS is interesting, though: With this older project I opened, I COULD import the same MP3 file that wouldn’t import into a new project, and this imported MP3 track played just fine from within Audacity. Does that tidbit provide any clues?

My System. I’m running Windows 7 Home Premium (64 bit) on an otherwise stable, well-functioning system (there’s one exception; see note below), as far as I can tell. The Audacity installer used was the .exe version. All Microsoft/Windows updates are applied in a timely manner; no updates are pending.

Oh, and something made me “look around” and I happened to notice a log file (attached) with some important-looking errors.

Any assistance you can provide would be greatly appreciated. Thanks in advance, folks, and have a good day.

Tony M.

Note: The errors reported in the attached Log.txt file remind me of a Windows error I get every time I create a new folder or try to rename an old one. Creating or renaming a folder initially causes an error message (Item Not Found), but clicking Try Again always works; this has been happening for several years with no other apparent problem associated with it. I’ve been led to think this Item Not Found problem – my ONLY known problem – may be occurring on systems where the Windows Library feature has been disabled by applying a popular third-party set of Registry edits, which I DID apply several years ago when the system was initially set-up.
Log.txt (21.5 KB)

If you apply Registry edits you accept the risk of that.

The Audacity log shows clearly that Windows is denying you access to C:UsersTonyAppDataLocalTempaudacity_temp . This causes the flat line where the audio should be.

It presumably works importing the same file into a project because that project is not located in the temporary directory that Windows is denying access to.

If you are not the “Tony” user, either log in as admin, or in Audacity, choose Edit > Preferences, then “Directories” on the left, then change the Audacity temporary directory to your own user space.

If you are “Tony” then you will need to fix the permission problem. Log in as admin. Show hidden files and folders thus: . Then right-click over C:UsersTonyAppData and choose “Properties”, then the “Security” tab. Make sure that “Tony” (or Everyone) has all the “Allow” boxes ticked.


Long story, short: I’m fixed! As always, I’m most grateful to you, Gale. For all the pleasure Audacity has provided me, I made another donation. Thank you, sir!

Yes, I knew/feared you’d say that, and I acknowledge you’re completely correct, of course. You can’t be trying to diagnose problems with systems that have been carelessly corrupted/mal-configured.

This suggestion is the first I attempted, and it worked. I selected a completely different location (C:TempTempForAudacity) that I believed to be accessible by any user/account.

I am that Tony, my system’s only Windows log-in account. Permissions is an area I never directly deal with, and since I didn’t like what I saw, I decided to not pursue this method further … especially since the Temporary Directory adjustment worked. In case you’re curious, for user Tony, only Special Permissions was not ticked, but all the Allow check boxes were grayed-out and no changes to the Allow column were permitted. If I fully understood how to use this particular Permissions dialog window, I might have been willing to make the necessary adjustments. However, as I said, all else seems to be okay. Translation: If it ain’t broke, perhaps I shouldn’t try to fix it. I realize that still might mean my system is not correctly configured/secured, but since I don’t know what I’m doing when it comes to permissions, I’ll just leave it alone.

I sure do enjoy using Audacity. If anyone is wondering why I don’t use my Sony Acid Music Studio instead, here’s why: I’m completely self-taught with using Audacity. I almost never need to read the Help section and I consider all the essential functions/interfaces I use to be highly intuitive. However, I cannot say the same for the Sony software; it may even be considered by others to be superior to Audacity, but that’s irrelevant. Audacity does everything I need to do, so in my opinion, that settles it.

Good day, Gale, and thanks again, sir.

Tony M.

Yes, you should be able to write to an arbitrary folder in C: as a standard user, except for restricted directories like Windows and Program Files.

In the “Security” tab of the folder’s Properties, you have to click the “Edit” button then select the user to change, or add another user “object” for example “Everyone”.

If the “Allow” boxes for yourself are greyed out and checked (except for Special Permissions), then you “should” have permission, and the greying “should” mean that permission is “inherited” from another folder that the current folder is in. On the other hand if one group you are a member of is allowed to write to a folder but another group you are a member of is denied, the Deny takes precedence.

Something is not right if you have to “Try Again” to modify folders but I agree if that’s the only problem and you are unsure about permissions it may be better to leave alone.


Thanks again, Gale. I’m much obliged for your willingness to provide that additional information about permissions in your previous post.

Have a good one and until next time, all the best!

Tony M.