cannot get sound with 4-usb audio codec

Until three days ago I worked successfully with Audacity 2.1.3 When I looked at the recording devices available I saw 3-USB audio codec and chose it.

Today I came to use the same Audacity 2.1.3. The 3-USB audio codec was no longer shown; instead I saw 4-USB audio codec. When I looked at recording devices, sure enough 3-usb had gone and 4-usb was there in its place. When I try to record with 4-usb audio codec I get no signal.

I installed Audacity 2.2.1 but encountered the same problem.

Why does 4-usb not work for me?
How can I get back to 3-usb which did work?

I have found that the Realtek codec gives bad results, a booming bathroom echo in the bass. Why is this?

In Windows, disconnected & disabled recording-devices can be hidden. Here’s how to make them visible …

I already have all disabled and disconnected devices shown. The issue is that when I select recording device as 4-usb audio codec I get no signal whereas when I select recording device as Realtek high definition I do get a signal, albeit one with booming bass. So … the questions are really these three:

how can I get good quality from the Realtek codec? I cannot believe I am getting the best out of it.
why do I get no sound from the 4-usb codec?
how can I reinstall the 3-usb codec that worked before?

I am attaching three files with notes as to history

I did show disabled and disconnected codecs but no usb was shown

fields of Athenry B.mp3” has been distorted by real-time noise-reduction, (that’s not Audacity’s fault).
You can switch-off that noise-reduction, (aka noise-suppression), “enhancement” in Windows recording devices …

Disable (untick) all the enhancements/effects you find in the properties of your recording-device if you want to record a musical performance.