Cannot get audicity 2.0.4 to work with alesis mutimix8usbfx

I acquired alesis multimix8usbfx two days ago. Connected laptop (Toshiba P750-13L with a Intel(R) Core™ i5-2430 M CPU @ 2.40 GHz 2.40 GHz running Windows 8 Pro 64 bit) with alesis multimix8usbfx. USB Audio Codec appeared in Device Toolbar and selected these drivers to try and record bass guitar via the mixer. Have not been successfull yet. Tried everything(?). Mulitmixer seems okay (can hear bass guitar via monitor in headphones). Drivers appearing seems to suggest that laptop and computer communicate. What am I doing wrong? Thanks and gegroet

Please describe exactly what happens when you try to record.


Hi Gale,
Thanks for the reply. I am trying to record an electric bass guitar (on full volume) plugged in the multimixer (set just under peak level) and connected with the Toshiba laptop through an usb connection. After connecting, the mixer’s drivers show up in the Device Toolbar. I can select 4 different hosts: MME, Windows Direct Sounds, Windows WASAPI and Windows WDM-KS. I have tried all 4 possibilities without success. I selected USB Audio Codes as Input (one mono channel) and HD Audio for Output. The VU meter in the Meter Toolbar doesn’t give any reaction. I have set the input slider in the Mixer Toolbar at almost maximum. When I press the red Record button sometimes the Pause button goes down as if I pressed it and nothing happens. At other times, after pressing the red Record button a flat red line appears as waveform moving to the right but no recording. Audicity works fine when I set it for recording the internal microphone. I think I have tried all the possible combinations I could think off (including using different USB cables. What else can I try?
Thanks and gegroet, Hans

Uncheck Transport > Sound Activated Recording (on/off).

Also try selecting again USB Audio CODEC as input in Device Toolbar even if you already selected it.

Perhaps you are not actually sending any audio to Audacity and are instead sending it only to the headphones of the mixer? Have a look in the manual for the mixer.


Hi Gale,
Thanks for your reply. I made me think. Ever tried to start a car without petrol? How stupid could I be. I had not opened the volume of the mixer. Everything works fine now. Thanks again,