cannot get audacity to record with external mic

Did all the workarounds I could find online…including the terminal fix which allowed me to record using internal mic (which I hadn’t been able to do until I did that fix). I then tried updating to most recent version of the software. My external mic comes up in the device options but just flatlines…can you help?
Thank you!

You needed terminal to record a built-in microphone? That’s odd. Mojave is still pretty well behaved. Which terminal fix?

Which microphone? Which machine? How would I buy what you have?

Which Audacity?


I tried terminal to fix the problem cause I wasn’t able to record using any mic at all at first. Once I did the terminal fix (see this video, I could get the internal mic to work. Turns out I might have been able to avoid that by just updating audacity which I did later.
I’m using a neuman connected through an Apollo twin and now I’m pretty sure that the Apollo twin might be the issue. I have no problem on my desktop Mac using the same set up but I’m traveling and need a traveling set up.
Latest version of audacity - I think it’s 2.4.2 I think?