Cannot export to ALAC

macOS: Monterey 12.4
Audacity: 3.1.3 64-bit
FFmpeg: downloaded from and installed to /Library/Application Support/audacity/libs

Following are the steps I am using:

  1. Open FLAC file 01 Logo, Main Title.flac
  2. File > Export > Export Audio…
  3. Configure the Save dialog as follows:

Save As: 01 Logo, Main Title.m4a
File Type: external program
Command: “/Library/Application Support/audacity/libs/ffmpeg_codecs.55.64bit.dylib” -i - -acodec alac “%f”
Show output: enabled

After clicking Save, the following appears:

“/Library/Application Support/audacity/libs/ffmpeg_codecs.55.64bit.dylib” -i - -acodec alac “/Users/scottkandel/Downloads/01 Logo, Main Title.m4a”

/Library/Application Support/audacity/libs/ffmpeg_codecs.55.64bit.dylib: /Library/Application Support/audacity/libs/ffmpeg_codecs.55.64bit.dylib: cannot execute binary file

If I modify the Command to “/Library/Application Support/audacity/libs” -i - -acodec alac “%f” the following appears:

“/Library/Application Support/audacity/libs” -i - -acodec alac “/Users/scottkandel/Downloads/01 Logo, Main Title.m4a”

execvp(/Library/Application Support/audacity/libs, -i, -, -acodec, alac, /Users/scottkandel/Downloads/01 Logo, Main Title.m4a) failed with error 13!

What am I doing incorrect?

Any assistance would be very much appreciated. Thank you in advance!

I should also mention in Audacity Preferences > Libraries, the following is displayed:

FFmpeg Import/Export Library
FFmpeg Library Version: F(55.33.100),C(55.52.102),U(52.66.100)

When I click Locate… the following is displayed:

Audacity has automatically detected valid FFmpeg libraries

the dylib is a shared library which can only be used by other programs, directly via command line. What you need is a standalone (static) ffmpeg executable.

Where can I obtain a “standalone (static) ffmpeg executable” and how would I use it?

you can download it eg on Usage would be exactly what you’ve tried so far:

/path/to/ffmpeg -i - -acodec alac %f

(the latest version should work, if not, FFMPEG 4.4.1 is definitely supported)

On there are downloads for snapshots and releases. I tried both the latest snapshot and release as well as version 4.4.1 and all of them cause Audacity to crash with Exception code 0x1

Operating system: Mac OS X
10.16.0 21F79

CPU: amd64
family 6 model 158 stepping 13
16 CPUs


Crash address: 0x0
Process uptime: 62 seconds

In macOS Security & Privacy I allowed the ffmpeg app.

In Audacity I am using the following Command:

“/Users/scottkandel/Temp/ffmpeg” -i - -acodec alac %f