Cannot export one project or its tracks

Hi! New here, but I couldn’t find any other topic on this.
So; i was having problems exporting one specific project, to wav or either individual tracks. so i looked at the log and finally installed ffmpeg 2.2.2 . I also installed Lame_v399.3_for_Windows.exe on the Audacity folder. I have Audacity 2.4.2.

Now: i can export for other projects, but not this specific one… The only difference between this project and others might be more tracks, more envelopes and effects.

Am I missing something?
Here s the log after trying to export this bad project:

12:39:45: Audacity 2.4.2
12:39:45: Trying to load FFmpeg libraries...
12:39:45: mLibAVFormatPath ('C:\Program Files (x86)\FFmpeg Audacity\avformat-55.dll') is not empty. Loading from it.
12:39:45: Looking up PATH environment variable...
12:39:45: PATH = 'C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0\;C:\WINDOWS\System32\OpenSSH\;C:\Users\Peter Storm\AppData\Local\Microsoft\WindowsApps;'
12:39:45: Checking that 'C:\Program Files (x86)\FFmpeg Audacity' is in PATH...
12:39:45: Warning: FFmpeg directory 'C:\Program Files (x86)\FFmpeg Audacity' is not in PATH.
12:39:45: Temporarily prepending ';C:\Program Files (x86)\FFmpeg Audacity' to PATH...
12:39:45: Checking for monolithic avformat from 'C:\Program Files (x86)\FFmpeg Audacity\avformat-55.dll'.
12:39:45: Error: Couldn't find symbol 'avutil_version' in a dynamic library (error 127: The specified procedure could not be found.)
12:39:45: Error: Couldn't find symbol 'avcodec_version' in a dynamic library (error 127: The specified procedure could not be found.)
12:39:45: avformat not monolithic
12:39:45: Loading avutil from 'avutil-52.dll'.
12:39:45: Loading avcodec from 'avcodec-55.dll'.
12:39:45: Loading avformat from 'C:\Program Files (x86)\FFmpeg Audacity\avformat-55.dll'.
12:39:45: Returning PATH to previous setting...
12:39:45: Actual avutil path C:\Program Files (x86)\Audacity\avutil-52.dll
12:39:45: Actual avcodec path C:\Program Files (x86)\Audacity\avcodec-55.dll
12:39:45: Actual avformat path C:\Program Files (x86)\FFmpeg Audacity\avformat-55.dll
12:39:45: Importing symbols...
12:39:45: All symbols loaded successfully. Initializing the library.
12:39:45: Retrieving FFmpeg library version numbers:
12:39:45:    AVCodec version 0x373466 - 55.52.102 (built against 0x373466 - 55.52.102)
12:39:45:    AVFormat version 0x372164 - 55.33.100 (built against 0x372164 - 55.33.100)
12:39:45:    AVUtil version 0x344264 - 52.66.100 (built against 0x344264 - 52.66.100)
12:39:45: FFmpeg libraries loaded successfully.


Audacity 2.4.2 has Lame built in, so you don’t need to install it separately.

The log tells us that FFmpeg for Audacity is correctly installed. (that’s good, but that’s all that it says).

What trouble? What’s happening?
Is it a big, multi-track project?
Where is the project? (which drive / directory)
Does the project play correctly all the way through?
Do you need to retain the project, or will it be sufficient if you can export it as an audio file?

The problem is it tells me :“Audacity failed to read from a file in C:” and doesnt export.

Currently it has 11 tracks, 1:30mins and the folder for the project is 130MB

I saved it on C:/MUSIC Audacity

The projects plays 100% perfect

I would prefer to keep the project… Although i could manage with the .Wav, so i can re-record it again…

Two things i forgot to say initially; dont know if it matters:
On this project i raised the rate to 48000hz, to match my Audio Interface, and the computer settings, and also lowered the quality from 36 to 24bits PCM, because it was interfiring and adding noise to my mic.
Also, i imported another version of the song to two new tracks, to add more depth.

Do you mean:
C:\MUSIC Audacity
or something else?

(writing to C:\ usually requires administrator access)

I saved it on the desktop before, couldn’t export, then to c:\MUSIC Audacity; now as we speak i saved it to c:\Audacity ; but still cannot export. (Exited the program and entered again after resaving)

I mean, it’s on a Folder on c:, not directly to the root.

Now the project is saved on the folder c:\Audacity\

You really shouldn’t be writing data to the root file system. User data should go into your “user space”
(directories below C:\Users**** )
A good place to put Audacity projects would be:

How much free space is there on your C: drive?

Thanks. By now i tried to save it pretty much everywhere… i first saved it to the desktop, and have had much bigger projects (700+Mb) saved without any issues…

I have more than 20gb free…

Try doing this:

  1. “Ctrl + A” (Select All)
  2. “Tracks menu > Mix > Mix and Render”
  3. Export
  4. “Ctrl + Z” (Undo, to get your multi-track project back)

Does the export work?

Thanks! I will try that in a bit. I might also have solved the problem; will do some tests to see if it’s all good.

problem solved:
I copy pasted every track to a new project, and could export to wav on every step with every new track.
I was reeally lucky that only exactly the two last tracks were broken; couldnt export after pasted any of those. (But they were a duplicate of the same, with a minor delay, and was exactly the easiest track to re-record. very luck)

Saved (to …\documents\Audacity) and is working fine with the exports after i recorded again the tracks.

I still tried to copy only the broken track to a new project; and did the mix and render, but even trying to mix, had the same “Audacity failed to read from a file in C:” problem.

So, for me is good; and if anyone has the same problems: copy pasting tracks one by one can identify the broken tracks.

Suggestion: would be nice if there was a easy way to identify broken tracks.
But all good for me now.


Do you still have the broken project?
If you do, try selecting one track at a time and apply “Mix and Render” (one track at a time). I would expect the “bad” tracks to fail. Is that what happens?

Exactly. Well that’s a good way to find them out yes.