Cannot enter selection start/end manually

I’m using Audacity 2.0.5 on Windows 7 x64 SP1.

Whenever I enter the start/end times of a selection manually (i.e., by typing the hh:mm:ss in the fields at the bottom) and then select an operation (e.g., trim or export selection) the selection start/end times are immediate reset to the start and end of the open audio file, so the operation is applied to the whole file.

Any idea why that would be? Am I doing something wrong or is this a known issue? It’s driving me crazy! :slight_smile:

It doesn’t happen when I select using the mouse pointer, but that’s no use to me because I want to select exact times.

James

Did the display follow you while you were entering the numbers and did the numbers stick? Did the start time stay put while you were entering the end time? Were you entering end time and not duration? There’s a selector for the second window.
Koz

Doesn’t work for me, either. I wonder what’s up…?
Koz

It works for effects, but not delete.
My Export Selection does seem to work, though.
Koz

It works for Delete, but not Destructive Backspace. That’s a Mac-ism.
Does the selection stick when you Effect > Amplify or any other effect?

When was the last time you restarted the machine?

Koz

The track needs to be selected before you navigate into Selection Toolbar. If you have “Select all audio in project, if none selected” enabled (checked) in Tracks Preferences (it’s enabled by default), then given there is no selection in the only track, Audacity will select all of that track before applying the effect.

If that preference was disabled (not checked) then you would not be able to apply the effect at all (the menu would be greyed out).


Gale

I think you are not seeing a Mac-ism but the documented keyboard behaviour in Selection Toolbar ( http://manual.audacityteam.org/o/man/audacity_selection.html#Selection_Toolbar ):

BACKSPACE Reset the last digit entered to zero

So if you had an “Length” on 20.444 seconds and changed the “0” (zero) to “1” by typing over the zero, BACKSPACE would change the “1” back to zero.

I will add to the Manual that you can’t thus use shortcut keys that work on audio while the focus is in Selection Toolbar (though I think it is fairly obvious).


Gale