Cannot Enable Noisegate.ny Plugin [SOLVED]

I am using a Mac with OS 10.10.5 and Audacity 2.1.3 When I open the Add/Remove Plugins window, the noisegate.ny plugin is listed as “New”.
I click to enable and the status changes, so I click “OK”.
However, the plugin is not listed to use. When I reopen the Add/Remove Plugins window, the noisegate plugin is again listed as “New”. I have tried this many times
and it always reverts to “New”.

Thanks for any advice

I think the first thing to try is updating Audacity to the current version (2.2.2) which you can get here:
Ensure that you follow the installation instructions exactly as written (on that page). Incorrect installation of Audacity is one of the most frequent causes for plug-ins not working.

I believe that the plug-in is in the wrong place.
It currently resides at /Users/tomas/Library/Application Support/audacity/Plug-ins/noisegate.ny

but I think it needs to be at Applications/Audacity/
I have no idea how to put it in the correct place. Thanks for guidance

According to the manual ( this location should be fine:
/Users/tomas/Library/Application Support/audacity/Plug-Ins/noisegate.ny

I downloaded the newer version of Audacity. Now when I attempt to enable the plug-in I get a message “failed to register” and what appears to be “Ill-formed Nyquist plug-in header”
How can I fix this?


Post the plug-in here so that we can check it.(See here for how to attach files to forum posts:

Here it is (I hope)
noisegate.ny (8.56 KB)

That looks OK and it works for me.

What are the exact messages?

In the Effect menu, do you see the effect “Adjustable Fade”? (scroll down below the “line” in the list)

  1. I posted the exact messages earlier. I said “what appears to be” because the word ILL was not clear…
  2. The adjustable fade was there and I enabled it.
    I really think it has to do with how I put the plug-in into the folder application support/audacity/plug-ins since the noisegate-ny is the ONLY plug-in visible in that folder.

I’ve just tried downloading noisegate.ny on a Mac Mini with Audacity 2.2.2.
I moved the plug-in to:
/Users//Library/Application Support/audacity/Plug-Ins/noisegate.ny
Enabled the plug-in in the effect manager, and it appeared in the bottom section of the Effect menu.

That’s normal as this is the location for user’s plug-ins, whereas the Nyquist effects that are shipped with Audacity are installed system-wide.

It’s possible that there could be a problem in one of Audacity’s configuration files. To fix that, these configuration files may be deleted, and they will be recreated with safe default values when Audacity is restarted. Here’s the steps:

  1. Ensure that Audacity is completely closed down.
  2. Go to ~/Library/Application Support/audacity/
  3. Delete the files:
  • audacity.cfg
  • pluginregistry.cfg
  • pluginsettings.cfg
  1. Launch Audacity (you should see the “Welcome” screen)
  2. Open the Effect Manager and enable noisegate.ny

I tried that, but I got the same messages as before…


If you open “Audacity menu > About Audacity”, does it say that it is version 2.2.2?

When you go to enable the Noise Gate plug-in, does the effect manager show the plug-in to be located at:
/Users/tomas/Library/Application Support/audacity/Plug-Ins/noisegate.ny

Is the version of noisegate.ny in that location identical to the one that you posted here?

OK…got it working. I downloaded the plug-in a second time and installed it.
It works.
Thanks for the help

Super :smiley:

I’ll mark this topic as solved.