Cannot dub over instrumental. Starts recording on the same area

I press record and it doesn’t create a separate audio track. It starts recording after the instrumental in the same channel. So I am unable to sing over the instrumental. I don’t know how to fix this issue.

I was using the scarlett solo plugin. I tried plugging in my blue snowball because it was more simple, but I still have the same issue. Please help!

It’s not the microphone. Audacity has always had an “Add-On” and a “New Track” option. One was R and the other was Shift-R on the keyboard. So just use the other one.

You can permanently change the behavior back the way it was in Audacity preferences.

Audacity > Edit > Preferences > Recording > Options.