Cannot continue using Audacity in its current state

Hello everyone. This is probably just more noise being added and I see a lot of posts pretty much saying the same things. Regardless, here we go, because I already made this account before seeing links to github threads reporting bugs.

I was running the latest version of Audacity, 3.1.whatever, on a Windows 10 PC to edit a podcast, using five audio tracks of vocal recordings and multiple tracks on top of that for any music and effects. The editing process of the podcast involves clipping out a lot of silence, cutting/pasting things to rearrange them, and copy/pasting soundbytes into a separate project file where I collect all of the soundbytes.

The 3.2 update has halted the process completely.

Removing the copy/cut/paste buttons seriously hampered my workflow I had established, but adapting to right-clicking the waveform didn’t take very long, and I’m also used to keyboard shortcuts though not when editing. That was a very annoying but ultimately minor change.

However, what happens when you copy and paste has brought my editing process to a stand-still. I won’t be able to get the episode edited in time unless I switch to a new DAW and start the episode over.
Why when I paste does Audacity freeze for multiple minutes every time? Because it is not copying and pasting my selection but the entire audio track thanks to Audacity’s new damage-free feature that does not work at all as intended. It only shows the few-second clip but is copying and shrinking four hours of audio every single time.

So, after much fretting and testing I think I have a solution to the problem; rather than copying the desired soundbyte, I’ll highlight it, right-click, split clip, and this will isolate the soundbyte from the rest of the track, able to be dragged and dropped as I want. Great!
But when you copy and paste this clip, Audacity still freezes for multiple minutes. Even though it’s really just the clip this time.
Okay, so I’ll keep it in the same workbook, people on here say that’s the problem now and I’m doing it wrong even though it’s criminally inefficient to copy/paste the clips into a separate track on the same project when you’re editing 4 hour recordings into 2 hour episodes and only have two minutes showing on the screen at a time so collecting the clips would require an incredible amount of scrolling.
Nope, this also causes freezing.

People say this is a reported bug and will be fixed soon, maybe. I don’t have time for that. I was ahead of schedule when this paste bug appeared. I even managed to finish editing an episode another member of the team needed help with on the new update and didn’t have these problems, but as soon as I went to start my own episode Audacity became unusable. I can’t even revert to the old update because the project was started on the new one; opening in 3.1 is still using the 3.2 tracks and all their issues, just with my copy/cut/paste buttons back.

Anyone recommend Reaper or Audition?

In Audacity 3.2.1, when you split a clip, it creates a new clip that contains the full audio of the original clip, so no it’s not “just the clip this time”, and that’s why you still get the delay.

Depending on how far into your new project you are, you may be able to go back to an older version of Audacity to complete your project.

If you don’t (yet) have many clips, you could export each audio clip as a “32-bit float WAV” file (Audacity uses 32-bit float internally, so the exported WAV files will be perfect copies). You could then import those WAV files into any other version of Audacity to rebuild your project.

Older versions of Audacity are available here:

Perhaps I’m not using specific enough language or the effects are not evident the second way; highlighting a selection and right-clicking “copy” and then “paste” is copying the entire file, as revealed by dragging the bar at the top to resize the selection. However, I cannot resize the pasted clip when adding the step of right-clicking and then using “split clip” to isolate the soundbyte first, so I assumed it was not bringing over the entire file resized down to the clip, which is good. It is hit or miss, though, only working without freezing sometimes.

I will try the method of exporting and importing, but will this not result in the same issue of simply opening the 3.2 file in the 3.1 version (i.e. old UI at top but the tracks have the 3.2 drag-bar at the top and associated 3.2 issues)?

“Smart Clips” was introduced in Audacity 3.1.0. If you go back to any version before that, then an “audio clip” is just the audio that you see, without any “hidden” audio.

In my testing, and according to the developers, copying and pasting a small portion of a track within a project does not cause all of the track audio to be copied. So copying a few seconds from a 1-hour track and pasting it into a second track does not cause that entire 1 hour of audio to be copied. In fact, no audio appears to be copied. It appears that Audacity is maintaining pointers to the audio within the project.

Pasting a small selection from one project to another does copy the entire track it came from. The developers are aware of this problem and are planning a fix.

There may be a problem with your current project, as evidenced by the long delays in completing any editing operation. You’d do well to export all your current tracks as 32-bit float WAVs, then import them into a new project in Audacity 3.2.1. Please try it and see if your problems are resolved.

– Bill

If you go back to any version before that

Macs let me install multiple different versions and go back to earlier ones.

Does Windows have anything like that?

I have an older machine that still runs, but isn’t very fast or convenient to use. I’m keeping it in case my current production machine falls over. Do you have anything like that?

I can’t even revert to the old update because the project was started on the new one

Do you have WAV or other high quality plain backups of all your original content; voices, music, effects? This note sounds like you recorded all your original content in 3.2 and froze the work in 3.2 clips and formats and now you’re stuck.

Did you do any 3.2 testing before you jumped in? This folds you back to having multiple versions on your machine—or two machines. This is where you get to wear your “Producer” hat in addition to your Engineer and Announcer hats. If you ever wondered what a Producer does…

The Producer is typing the complaints on his message thread.


New project, Generate Chirp, 20 minutes
Select a small portion
Right-click > Split Clip
Create new mono track

I can expand the pasted clip to the left but not the right. This appears to be a bug and that the pasted clip should be expandable in both directions.

– Bill

Hi Bill,

testing on W10 with 3.2.1 I can expand that copied clip in both directions:
Bills's clip issue.png

Just tried it again, and now it works :frowning:

– Bill

I tried the same experiments you report at the GibHub thread (before I’d read your comments there) and I got the same results. No increase in file size when pasting little clips all over the place in a 3.21 GB project. Copying 3 minutes from the project into a new project took over 45 seconds (with spinning beachball of death) and the new project is 3.22 GB in size.

Audacity 3.2.1, macOS 13.0, iMac 27", 3 GHz 6-core i5

– Bill

Under the hood it is more complex than it appears to end users.

Initially, Audacity is using pointers to the same underlying data, so making “smart clips” does not significantly change the size of the project, but when you start modifying the data in clips by processing, then copies of the data are made, which can make a huge difference to the size of the project.

Yes, but that has always been the case (at least going back to 2.4.2 which is the earliest I can test). So the introduction of smart clips does not make for larger file sizes.

– Bill

Indeedy, testing proves that to be the case. I have added to the issue thread.

@Bill, I’ll try to do some comparative testing with 2.4.2 and earlier tomorrow (Audacity is passively waiting for a Timer Record right now).


but older versions of Audacity didn’t have hidden data in clips.

Here’s a simple example comparing project sizes while working in Audacity 3.2.1 compared with Audacity 2.4.2.
The sizes are in MiB, and include all files associated with the project.

Audacity 3.2.1    |     Audacity 2.4.2
Action: Generate a 10 minute track, mono, 44100 Hz:
   102            |        102
Action: Split into 10 equal clips:
   126            |        120
Action: Select the entire track and fade-in
   326            |        222
Action: Save and quit:
   214            |        102

Note that while working, the 3.2.1 project grew 50% bigger than the 2.4.2 project, and the final saved 3.2.1 project is double the size of the 2.4.2 project.

Good example, I hadn’t thought of that scenario.

So what is going on that causes the 3.2.1 project to double in size? My guess: each clip now has 1 minute of changed audio. That’s 10 minutes of changed audio that needs to be stored, along with the 10 minutes of original audio. Thus a doubling in project size.

Note that if you merge all the clips after doing the fade-in, the project reduces to the original size, as expected.

– Bill

Good plan Bill - “Tracks > Mix > Mix and Render” is also a possible work-around:

So I Generated a 1-hour chirp, then “smart-clip” trimmed the edges, resulting in a clip with five minutes of visible audio. I then selected the track, and Tracks > Mix > Mix and Render. The edges of the resultant track are no longer expandable and the saved project size is 54MB (the one-hour chirp would be 628MB).

Note this is only going to work well for a single clip as with multiple clips you are going to lose your clip structure and any white space between the clips will now be converted to silence - which will take up space.

Also note that pasting clips into a New Project is where most of the difficulties begin. Try pasting the shortened clip into a small section of the original project then mix and copy the “mixed” clip to the new project.


see my 2.4.2 versus 3.2.1 tests in this parallel thread:


We’re talking to ourselves here. I’d love to hear from LintGravy if they tried exporting and importing into a new project. It would at least tell us (and the devs) whether this was a performance issue related to smart clips, or a damaged project.
– Bill