Cannot change sound device

Hi guys. I’m running Audacity through a Mac and I’m using a USB connecting mixer. When I plug the mixer in, then open Audacity, I’m unable to select it as a sound device for input (usually says USB audio codec) I can find it on the mac’s audio device settings and can switch to it there. It picks up sounds through the mixer, but when I try to change it in Audacity it still doesn’t show up.

Any thoughts?



As usual, questions rich in models, versions and part numbers are good. What kind of Mac, which OS, which mixer, etc. etc.? Also, fill in the info from the pink band above.


usually says USB audio codec

Wait. Usually? It all worked last week and now it doesn’t? Did you do the Yosemite upgrade?


I’m running a Alesis Multimix USB to the mac. When I said usually, I meant USB audio codec is what shows up on my PC.

I’m checking now. The mac is my drummer’s who wants to record his parts from his computer. Would moving from PC to mac mess with the way Audacity runs?

You could look at the pink panel at the top and answer the questions. Have you tried Transport > Rescan Audio Devices from the Audacity Menu Bar? You have to connect the USB device before launching Audacity, or do the audio device rescan. That’s the same on Windows and Mac.