Cannot adjust input level [SOLVED]

Using Audacity with ASIO 2.0.3 .exe obtained. On XP. Cannot adjust input level for recording, it’s always the same no matter what I do in the system’s sound control panel or whatever was suggested in the earlier threads for this problem. In Directsound the adjusting works fine but I want to use ASIO. Is there anything to do, use a different version of Audacity or just give it up altoghether for this matter? Thanks.

ASIO is not a cure all. Are you sure you need to use ASIO?



Is there any other software that works with ASIO and without these problems, Audition perhaps?

Then that build is not made by us. We don’t provide binaries with ASIO support. Please compile Audacity 2.0.5 or our latest code with ASIO support, because we can’t help you with builds made by third-parties.

I assume you are aware of the security risks of doing that, now that Microsoft does not support XP?

What exactly are you trying to record? Overdubs, and with what device?

Does that device support ASIO properly? Does it have proper ASIO drivers meant for XP?

Does that device have hardware playthrough? On XP built-in sound devices quite often let you unmute playback of the input so you could hear yourself recording with minimal delay. You can adjust recording latency after the recording thus: .

No idea, please see the questions above.

Have you tried the already-compiled Nightly Builds ? You could try Windows WDM-KS Host in those builds. WDM-KS could just possibly crash or freeze your machine, hence it is not released yet. But if it works with your device its latency is almost as low as ASIO.


Well, I have tried that Audition and didn’t like it, luckily I didn’t pay for it. Beside the ugly interface it didn’t allow for input level adjust as well, so basically it’s worthless. Audacity in combination with iZotope is all I need. So you’re saying I’m not gonna get any sound droputs working in 32bit float using that WDM-KS? I’m just trying it, input level adjust works just fine and the sound seems ok, I hope it stays that way. There’s a registry patch that allows updates for XP and it works just fine too.

And to answer Steve, I’m ripping some of my vinyl and cassette collection in order to transfer it to CD. One tape I took to rip recently is slightly going into peaks on occasion (and my deck has no output level control) thus the problem from the topic’s title bc I didn’t trust anything else but ASIO via my Xonar soundcard.

The problem seems to be with your Xonar device or its drivers (poor ASIO support under XP)?

An input level slider that only scaled down the distortion to give you quieter distortion isn’t going to help you.

I’m not saying anything - it depends on the device. Are you saying you get dropouts with Windows DirectSound? DirectSound should have less latency on XP than on later Windows, though it is not as fast as WDM-KS.

And if you are only recording tapes and records there is no reason not to set the buffer higher to safeguard against dropouts.

Well needless to say Microsoft takes a dim view of that . Clearly the updates you will receive are actually for Embedded and Server 2003 and are not the patches for XP that Microsoft are still supplying to large organisations in return for payment. So you may destabilise your computer or not get the protection you think you’re getting.

Now, if you can find the registry patch that tells Microsoft’s update servers that the computer is working for a “paid up” local authority, you may be in business.


Nah, people have had this problem with input levels on Vista and 7 with no help, your forum is full of it. But who cares when it works now this way for what I need, cheers.

It seems odd to me that your trust is in non-standard drivers on an obsolete operating system that is hacked to allow updates that are not designed or tested on that operating system with an unsupported third party version of Audacity. :confused:

Recording level control of USB audio devices via software is rarely supported by USB hardware or the device drivers. Audacity does not provide low level device drivers or hardware and is not responsible for hardware or driver limitations.

As your reported issue applies to other software as well, it clearly isn’t an Audacity issue.

Copying vinyl and cassettes to a computer with Audacity does not require ASIO, but it does require hardware and drivers that work on the given computer system.

Excellent. I’ll mark this topic as solved.