Cannnot open files

Yesterday I tried to open a file and got this message:

Audacity failed to write to a file.
Perhaps /Users/______/Library/ is not writable or the disk is full

As far as I could tell the location is in fact writable and the disk is not full. I don’t know what to do. Please Help.

I haven’t been have any problems until yesterday. I am a noob when it comes to computer stuff so the more detailed your help the better.

My attempts at fixing this were:

I turned off the mac and turned it back on. No change.

Uninstalled Audacity and reinstalled. No change.


Is the “______” your user name?

How long is the recording and what size (in MB) is the file?
What format is the file that you are you trying to open?

Yes. the “_____” is my username.

The recording is 1 hr 15 min 57 sec, and 37.3 MB
The format is Apple MPEG-4 audio [.m4a]

I haven’t had any problem with these kinds of files before, until the last few days when I started getting the popup notification.

The file above was not the first time I got this error. I also had this problem with several FLAC files that ranged upto 5 mins 44 secs in duration, that were up to 36.3 MB in size.

Thanks for the response.

What is the full name of the file, and where is it?

name of the file is:

20190131 204858.m4a

file location: Its on an external hard drive that is plugged in to the mac all the time. I moved the file to the desktop to see if it would open from there, but it didn’t.

Luke’s Music/zzz Untested Downloads/Luke’s Album a Day/Voice Memos

Does the file play correctly all the way through in a media player?
(listen to it all the way through - an unexpected glitch during playback could indicate corrupt data).

I played the file all the way through in iTunes and had no problems. No glitches that I could hear.

How much free space is there in “/Users/______/”

I have resolved this issue.
I was having other problems with the Mac so I contacted apple support. It seems it was permission issue. I don’t what the cause of the issue was but restoring or reinstalling the operating system [Catalina] I can open files in Audacity again. Thanks for your help.

Glad to hear you’ve resolved the problem :slight_smile:

My problem has recurred.

So far I’ve tried:

  • delete app and reinstall [several times, but I haven’t since the 2.4.1 update yet]
  • change location of temp folder
  • reinstall MacOs [several times]
  • Changing permissions on folders
  • complete wipe of the Mac and restored from Back up.

Each of these has worked in the short term [from a day or two, to a month]! then either the process stopped working when the error recurred [change temp folder location/permissions], or I have gotten annoyed with the error recurring because it seems like it is not a long term fix [reinstall MacOs/ wipe etc]. It’s been very frustrating. It’s been happening since the Catalina update.

Today I think it might have something to do with the temp folder. I use Audacity a LOT, and it does seems to work for a little while after I try some of the fixes. Like I’m reloading the folder to almost full each time, so it takes a little time to Refill. But I check the temp folder and it is empty. But as you can probably tell I’m flying blind here.

Also, when I get the error some other stuff happens with the Mac. If I try to download something, it constantly interrupts, citing unrecognised errors. And other Temp File-ey programs stop working properly too, which is why I’m lead to my Temp file suspicion.

I don’t know if this is where I should be writing all this, but I’ll cut and paste it somewhere.

I hope you can help. I’ve tried Apple support [where I got the instructions to do a lot of my attempted solutions] but they are all out of ideas and are recommending and suggested I look into the app, which is why I’m here.

I look forward to hearing from you.

Do you mean, when you download something from the Internet with Safari?


If I download something on Safari the download is interrupted and I have to start again. Sometimes if I retry the download enough times I get lucky and it works.

I have tried downloading the same file on Firefox as well. It also gets interrupted but I can resume the download on that browser. But it still gets interrupted multiple times.

This only occurs after I get that error message on Audacity.

Is there any error message or warning message when the download stops?

You didn’t reply to this, but it may be relevant.

Via Preferences: Directories is says the free space is 65.5 GB

/Users/unsername/Library/Application Support/audacity/SessionData

is empty

Can you sense the sea of question marks over our heads? All of us including Apple?

All that is so not normal.

Lets back out a little. What’s the show? Why are we here and what’s the Mac’s job?

This may be a little different between our machines.

Desktop > Go > Computer > Right-Click or Control+Tap Macintosh HD > Get Info.

Read Capacity and Available. Close.

Then Desktop > Apple > About This Mac > More Info… > Storage.

Screen Shot 2020-06-27 at 18.27.53.png
This is almost certainly going to be different. See how far you get.

You can take a picture of a portion of the screen with Shift+Command+4 and draw a box around what you want. Do that to the window that looks like the picture I posted. Then scroll down from a forum text window > Attachments > Add Files and select the picture you just made.


Is this what you meant?
Screen Shot 2020-06-28 at 12.55.39 pm.png
Screen Shot 2020-06-28 at 12.54.32 pm.png

Just to report where I’m at.

I got on to a senior Apple support dude we came up with plan of action.

  1. Wipe the Mac
  2. Reinstall factory os
  3. Upgrade os to mojave (ie os before Catalina)
  4. Run audacity for awhile from there and see what happens. Add files as needed from backup, not an entire backup
  5. If that works well either stay onMojave or upgrade to Catalina and see if Catalina is the issue.

When doing step 1 we found something wrong with the fusion drive my Mac has. I’m not sure of the exact terminology but the fusion drive didn’t look like it was working the way it is meant to. Maybe the wrong part of the drive was being used to store data [which would explain the error, the Apple support dude seemed confident would fix the issue, but so has every other Apple support person when a little Mac mystery has been revealed.]

I’ll see how it goes on Mojave until I have to do a backup and take it from there. ATM the moment I’m reconfiguring stuff back to Mojave and then I’ll get back into using Audacity more regularly and I’ll see how it goes.

Thanks for your help out there.

Ps. The Apple support dude actually has used audacity and was into audio stuff which was a big help too.