Can’t hear anything while input cable is plugged in.

I was using a very old version of Audacity which was working fine on my windows 10 64x laptop. Then I downloaded the latest version of Audacity, 2.4.1 and set the same preferences. Now, even with the software playthrough option selected, I get no sound whilst recording and can only hear playback if I unplug the input cable from the USB port. I have tried with both the Microsoft sound mapper and the high definition microphone/ speakers, it makes no difference. I have specified Audacity in the list of apps with permission to use the Windows microphone and speakers. Any help would be appreciated. Thanks.

I think that more details are needed about how are you connecting your devices, which is the source of the sound you want to record, and things like that.
Can you explain someway that is it possible to figure something like the image above out?

Thanks for your reply.

The set up is very similar to your diagram. A cassette player output is connected to a Numark turntable and the output from that is via USB cable to the computer. The signal is being recorded, I just can’t hear the recorded material until I disconnect the usb cable. I can see the sound level meters in Audacity working even though I can’t hear anything. Somehow, the playthrough selection is not having any effect.

With the old version of Audacity which came with the Numark turntable, everything worked fine.

Thanks again.

Since my last reply, I have fixed the problem. The Windows sound manager was defaulting to USB speakers, when I disabled them and only had the Hi-Def Audio speakers active, it all worked fine. Thanks for your attention.