Can not record with RME Babyface, probably USB issues?


I have been using Audacity for occasional recording purposes for about six years now. I am using an RME Babyface connceted via USB. Everything worked great.

Until I bought a new computer. Now, when I try to start a recording within Audacity I get this error message:

Error opening recording device.

Error code: -9999 Unanticipated host error.

I tried all the different drivers (DirectSound, MME, WASAPI) without success.

I found out that the only way to get this to work is to start Audacity, unplug the interface and then plug it back in. Only then I can record.

And I just realized that I can not record through the RME Babyface from within DaVinci Resolve/Fairlight either. Same solution: Unplug, then plug back in.

In Cubase the interface works just fine, same in Reaper. Those use ASIO, as far as I know. But Audacity used to work just fine before.

What could be the cause of this and I how can I solve it?

I will add that I have an issue with my USB-Webcam as well: When I try to use it for a YouTube-Live-Stream the YouTube-Website says the camera is in use which it definitely is not. I have gone through the settings in windows many times, blocked camera access for other apps/software and so on. I mention this because I sense a relationship to my interface issue. Maybe there is an issue with accessing USB devices?

So maybe this is clearly an Audacity issue, maybe only in part, maybe not at all. And maybe you can help me fix this.

I suspect that it’s a driver problem. According to RME, the Babyface drivers support “Windows 7 / Vista / XP SP2 (32 & 64 bit)”, but I’m guessing that you are using Windows 10. (

We don’t have any detailed information about RME products. You may find a better workaround, or even possibly a solution, by googling for “Babyface Windows 10” or similar. Other than that, I’d suggest that you continue to use your current workarounds.

Thank you steve. The RME USB Drivers for the Babyface do infact support “Windows 7 to 10”. And they they do and did work just fine in Windows 10 just not in the case of Audacity and a few other applications. I thought someone here might know about the way Windows grants access to USB devices and how that relates to an App like Audacity.

In Windows 10, you need to grant access for applications to use recording devices. See:

I have taken care of those, that is what I was referring to in my first post (blocking access etc), I just did not know the names of these steps in the English version of Windows.

Unfortunately this does not fix the issue.

Does the Babyface fully support Windows 10?
The RME website only says “Windows 7 / Vista / XP SP2 (32 & 64 bit)”, and Google throws up other people having problems with the Winodws drivers (not ASIO) with the Babyface on Windows 10 (example: Babyface Windows Driver Not Working After Windows 10 Update (Page 1) — FireWire & USB series — RME User Forum)

That thread is almost four years old.

This is the official driver description from the RME website:
“Windows 7 to 10 PnP driver for Fireface UFX, 802, UCX, UC and Babyface/Pro”
(from )

When it comes to drivers I know of no company that beats RME.

I’m not sure about this.

The website says (in the old Babyface documentation) that the Babyface is compatible with “Windows 7 / Vista / XP SP2 (32 & 64 bit)”.

The driver download says (on your linked page) that:

  1. driver_usb_win_1168 is compatible with Windows 7 to 10 PnP.
  2. driver_usb_win_1168 is “Compatible to classic Babyface”.
    but although implied, it does not actually say that the Babyface (hardware) is fully compatible with Windows 10.

As you are seeing this problem in DaVinci Resolve/Fairlight as well as Audacity, and you have not suggested that there are any other problems with your computer, I am still inclined to think that it is a compatibility issue.

I am not able to offer any further help as I do not have a Babyface for testing, but searching Google may come up with a solution, otherwise, at least you have a workaround.

If you have any experience in C++ programming, it is possible to build Audacity with ASIO support, but due to license restrictions it may only be built with ASIO support for personal use (the ASIO SDK is “non-redistributable”).

Rest assured that the Babyface works fine with Windows 10 and I have used it many times with Asio drivers. It should also work without these if you use the analogue line output in to your computers line input and if you do this the only function of the USB connection would be to provide power to the Babyface. This would eliminate the need for Babyface device drivers. By unplugging the unit and plugging it back in you may be changing the mode of the device. I suggest you read the manual about using class compliant mode if you do not intend to use the ASIO version of Audacity. If you let me know what kind of inputs you are working with and confirm that you do not need ASIO I will run some tests with my Babyface on the latest Windows 10 Pro. Do you have the RME breakout adaptor with phono connections?

Update: I’ve done a few experiments. ASIO works fine at almost any sample rate. WASAPI seems to only work at 44.1KHz and it is vital to set this up in RME USB settings tool and in the windows control panel ( mmsys.cpl ) then set the project rate to match before attempting to record. Any other settings either result in a device error or an incorrect sample rate error. So far I have only tried it with a 2.3.3 alpha build. I’ll try the standard no-ASIO one later.
Good news I think:- The latest off the shelf 2.3.3 is working faultlessly with wasapi and the analogue (1+2) RME Babyface input device selected. The project sample rate can be set up to 192KHz and the device follows that setting. Now I have just got to compile the latest source with ASIO to see if that works too.

I think I’ve got a handle on this now! I’ve just compiled 2.3.3 November version with ASIO and I got these sample rate mismatch problems again. Setting everything to 44.1 KHz ( windows device in mmsys.cpl, RME USB settings tool, and audacity default preference sample rate) monitor and record worked and also I could change the sample rate within audacity and record a new track at any sample rate the device could handle. When I tried to use a different sample rate for each then restarted audacity it all went wrong again. Then I noticed that as Audacity was starting up it changed the device sample rate back to 44.1 even though it opened the project with the preferred sample rate. If you go back to the RME tool you can put the rate back to match your project rate ( without restarting audacity ) and it all works correctly again.

So as a work around set all the default sample rates to 44.1 then once Audacity is running change the project rate to whatever you require. The rate shown by the RME USB tool doesn’t change but the sample rate in Audacity changes as expected. The only trouble is that I can’t tell whether the babyface is sampling at the higher rate or whether Audacity is just upsampling. So for guaranteed best quality ASIO is preferable in my opinion.

There does seem to be a bug in Audacity in that when initializing the device, presumably using exclusive mode, it sets the sample rate to 44.1 irrespective of the preferred rate which will be set by the project moments later.

Thank you.
I have gone the different route and uninstalled and reinstalled the latest Audacity version again as well as the Babyface drivers again. Audacity seems to be working now without any workaround.

Thanks for the update.
It’s very unlikely that reinstalling Audacity would make any difference, so my guess is that reinstalling the drivers fixed it.

… and it could also be that those dodgy Realtek ASIO drivers are causing issues again.