Can not get signal on audacity

I ve try couple of times to record from a mixer to audacity but i dont know why i dont get any signal in the monitoring and so nothing get recorded.
i try to give more infos as possible:
mixer h&h xone 23 2x rca into record plus to minijack

OS X 10.9.4
plus soundflower set on buil in output.

Please help! ; )

Ideally you would connect a non-USB mixer to the stereo line-in of the Mac and record from the line-in. You would monitor directly in the mixer. But you don’t seem to have a line-in. What is the Mac model? See Apple menu > About This Mac… .

This might help XONE:23 User Guide - Allen & Heath.

Is that Play Thru button in LineIn depressed?

Can you choose “Built-in Output: Headphones” as playback device in Audacity?

You could buy a USB interface to connect the mixer to if the Mac lacks a proper stereo input.


thank for your answer:

Screenshot at Mar 26 15-15-37.png
Ive already read the manual and it has rec.dedicated rca input plugs that i connect into the audiojack thru his own microjack plug.

no as far that i know shall be turn on during the rec. Anyway i already tried to depress it and it doesnt change anything.

Screenshot at Mar 26 15-27-28.png
i have tried already to set it on soundflower but it does not change anything.

i dont think i need it based on all infos ive read till now.

If you care about what you are recording, you do. Recording mixer output from playback of the output is very suboptimal.

Can you hear the mixer output in the Mac before you start recording it?

Have you turned up the input and output levels in Sound Preferences?

Have you tried running Soundflowerbed instead of using Line-In?


The 2012 MacBook Pro 13" had one connection you had to reverse in Mac System Preferences.

Apple (upper left) > System Preferences > Sound.

My 15" starts dividing up the world into Input and Output menus, but I don’t think you have that option. You get to pick one. Once you select Input/Recording, you should be able to pick the same thing in Audacity Device settings. Built-In Input??

A friend of mine had one, so I can’t look up the exact settings.


Also note because of this restriction, you can’t have headphones and record at the same time.

The 15" had both which is why I bought it.


Another note. Nowhere in here should you be using SoundFlower. That’s only for self-recording or capturing YouTube or web sound.


Do you remember where you got the idea you needed SoundFlower to record your mixer? Did you see that in the Audacity manual?

Are you following a YouTube posting? Audacity doesn’t post YouTube instructions because they’re really rough to get right and keep up. Because of that, many of them are wrong.


probably but i wanna just try to let it work this way for now.

never tried before now . i thought this is the way and doest work.


i tried them togheter and sound f only.

thanks for the help

yes i post a screenshoot about that above

nope have to be set on soundflower 2 the same u swich on sound pref normally

okey thanks

actually not cause for the reasons you listed.

Please use the Quote tags correctly. We can’t follow your messages!

You should not be using SoundFlower. Full Stop. Switch to Input or Record in Mac Preferences. When you do that, it should be possible to play music in your mixer and see it in the Mac bouncing light sound meter.

Again, I don’t have one of those in front of me so this is a little magic. The Mac has to know about your mixer before you even start Audacity. Audacity gets its sound from the Mac.


so you suggest me to set what in here?
Screenshot at Mar 26 18-59-54.png

If so, the Sound Preferences Input and Output tabs had a “Use audio port for:” dropdown. I don’t know the icon that was used on the machine for such a reversible audio port. Was it headphones, and no different to latest Macs that have only a TRRS headset port?

If you have that menu, choosing “Sound Input” there should change the Input tab from “Internal microphone” to “Line In” (which is what you should be recording from):


Mine looks like this:
Screenshot at Mar 26 22-21-24.png

From reading it looks to me that this Mac model might be expecting a TRRS (four-position) input jack, because it supports iPhone headsets and those headsets always have a TRRS connector.

If so then the reason your input cable is not seen in Sound Preferences may be because you don’t have a TRS to TRRS adaptor, but if this is the reason then that input simply isn’t suitable for high level RCA outputs from a mixer. Even if Line-In could play the input through the Mac, the sound will probably be distorted.