Can NOT dismiss "Welcome to Audacity!"

I’ve installed Audacity 2.0.5 on both my MacBook Pro running OSX 10.6.8 (Snow Leopard), and my Mac-Mini running OSX 10.5.8 (Leopard). I downloaded the audacity-macosx-ub-2.0.5.dmg file. On 10.6, the “Welcome to Audacity!” page is active and can be processed, including closure. On 10.5, this same page shows up in the Window list, but nothing can be done with it. Essentially, it’s an inactive page with no active checkboxes or buttons, not even the window buttons in the upper left corner. I can click on the standard Audacity page (Toolbar Page), and the Welcome page goes behind it, and I can do everything normally. So I’m reporting an “issue” with Audacity in Leopard. Also, when I Export a file as type AIFF, and append the appropriate .aiff suffix, the file is saved as an Audacity file, NOT an iTunes file. The Creator code is “auDy”, not “hook”.

I would probably select AIFF as an export type and then not put anything after the filename including the dot. Let Audacity put the .aiff on for you. AIFF is not an iTunes file. It’s a file type that iTunes likes to snuggle up to because it has better metadata support than WAV, but WAV, the Audacity default works just fine as does MP3, and has the additional advantage that WAV opens up on all three different computer types, unlike AIFF.

Have you ever done a Repair Permissions?

Go > Utilities > Disk Utilities
Select your System Drive and Verify disk and then later, Repair Permissions.

That may clear the problem. Let us know.

Screen shot 2014-05-03 at 5.24.18 PM.png

OK, I’m letting you know… I did “Verify Disk”, which is OK. I did “Verify Permissions”, which are also OK. Lastly, I did “lsregister -r -domain system -domain local -domain user” followed by “lsregister -r /Developer/Applications”. When I launched Audacity, the Welcome page was frontmost, but inactive, and nothing could be done to dismiss it, other than to hide it by clicking on the main Audacity page.

I did “Verify Permissions”, which are also OK.

Which isn’t what I said.

I did “lsregister -r -domain system -domain local -domain user” followed by “lsregister -r /Developer/Applications”.

What does that do?
List Register, Recursive Argument…


I think I would try for a hard re-install.

Drag that folder to the trash

/Users/koz/Library/Application Support/audacity
And that one. Substitute your username in the path.

Reinstall Audacity and you should get a well-behaved welcome screen and plain, unmodified option settings if it’s successful.


I did exactly what you said:

Leopard-Guertin:~ dickguertin$ cat audit.trail
Leopard-Guertin:~ dickguertin$ cd “Library/Application Support”
Leopard-Guertin:~/Library/Application Support dickguertin$ rm -rf audacity
Leopard-Guertin:~/Library/Application Support dickguertin$ cd
Leopard-Guertin:~ dickguertin$ cd /Applications
Leopard-Guertin:/Applications dickguertin$ rm -rf Audacity
Leopard-Guertin:/Applications dickguertin$ cd
Leopard-Guertin:~ dickguertin$

I then opened the audacity-macosx-ub-2.0.5.dmg and dragged the Audacity folder to my Applications folder. I then opened and took a picture of the screen. Note that Audacity is active (upper-left name shows active application), but the Welcome window is inaccessible.

I don’t know.
Is there a reason you’re doing this on the command line instead of letting the GUI do it?
Audacity runs just fine on Linux.

This issue with the Welcome Screen (and the Log window) has been reported with both OS X 10.5.8 and 10.6.8 so it is not solely a Leopard issue. Is the Mac Mini that has the problem a PPC Mac and the 10.6 machine an Intel Mac? As far as we have been told, all the reports are on PPC Mac.

Let us know then I will file a bug report.

Meantime the obvious solution would be to turn off the “Welcome Screen” at Audacity > Preferences. Choose “Interface” on the left. Uncheck “Show ‘How to Get Help’…” , click OK and restart Audacity.

If you cannot access Preferences, edit the audacity.cfg settings file. To do this, quit Audacity, open Finder, Go > Go to Folder and type:

~/Library/Application Support/audacity/

Open audacity.cfg. Find the line that says


If you don’t have a [GUI] line, add it.

Underneath the [GUI] line, add:


Save the changes to audacity.cfg then restart Audacity.


To Gale: Thank you for the “interface” suggestion, which has eliminated the Welcome page on subsequent launches. My Mac-Mini is a 1.66GHz Intel Core Duo, running OS X 10.5.8. I’m doing everything with [GUI], except for the Terminal commands I included to show how I eliminated a prior Audacity, following buanzo’s instructions. The comment from Koz doesn’t make sense to me. I don’t have access to any Linux machines, and I wouldn’t be able to use my USB PnP Audio Device (USB Cassette Capture).

If this problem with the Welcome page is a known bug, hopefully THIS thread will provide others with relief. For now, I’m satisfied using the work-around.

To Koz: Re: lsregister. I recommend reading what’s on the following web-page:
Also, on any Mac OS X 10.4+, try: man lsregister
Finally, search the web for “mac lsregister process”.

I hope that’s satisfactory.

Thanks, that’s a shame. Koz could not make the problem happen on an Intel MacBook Pro on 10.5.8, so there is some other variability. Two others with that problem have iMacs.

The only other suggestion I have (which I wouldn’t blame you if you didn’t want to bother with) would be to turn the welcome screen back on then try the previous Audacity releases 2.0.4, 2.0.3 and so on to find out in which release the problem started: .