Can no longer record output after buying new headset


Been using Audacity for years now, to record audio that my PC is playing via the Enable Stereo Mix feature with Windows. Recently, I bought a new Skullcandy Wireless Headset, and now Audacity can no longer record output sound playing directly on the computer like it used to. I fiddled around with the settings both in Audacity and in Windows and cannot find the solution myself, so I am turning to you all for help. Hopefully this is not a compatibility issue where I’m SOL.

Here is what shows up now for Sound settings in Windows (and in Audacity)
Speakers (Realtek High Definition Audio)
Realtek Digital Output
Realtek Digital Output(Optical)
Speakers (Skullcandy GMX Stereo Transmitter) ((this one shows audio levels while sound is playing)

Microphone (disabled)
Line In (Disabled)
Stereo Mix (Enabled and default device)
Microphone (Skullcandy GMX Stero Transmitter) ((Enabled / Default Communications Device))

The way the wireless headset works, is that it has a little adapter hub thingy. One port on it is for coax that plugs into the Speakers port on the PC. Another is USB and I think that is just for power. The adapter is transmitting wirelessly to my headset.

I realize I could get around this problem by just swapping the system out for my old headset when i want to record using Audacity, but I would prefer a situation to make it work as-is. Any advice?

I have a tried a variety of capture options in Audacity. I’ve basically tried every combination of options from the dropdowns. It records silence.

I moved this to the Windows board.

Thanks for giving the devices you see.

The Realtek stereo mix almost certainly won’t be able to record from the SkullCandy because it is a different device than Realtek, notwithstanding it has a connection to the speakers output of the built-in sound device.

Look at Help > About Audacity… and make sure you have the latest Audacity 2.0.5. If not, get it from .

Then try using the Windows WASAPI host as described in the Manual ( ).

  1. Open Device Toolbar .
  2. In the first (Host) box of Device Toolbar, choose “Windows WASAPI”.
  3. In the second (Output device) box in Device Toolbar, choose the SkullCandy.
  4. In the third (Input device) box in Device Toolbar, choose the (loopback) input for SkullCandy.
  5. In the fourth (Input Channels) box in Device Toolbar, choose mono or stereo.
  6. Start playing the audio you want to record.
  7. Press the big red Record button in Audacity.



Thanks for this solution, it has worked like a champ. As a small caveat, I had to set Audacity’s Output to Realtek Digital Speakers, as when I set it to the Speakers Skullcandy it gave an unable to access device message. As far as recording, it is back to working perfectly now.

Upgraded from Audacity 2.0.3 to 2.0.5

Thanks again!

Thanks, that’s interesting if it applies generally to wireless headsets.

Really, if what you are recording under WASAPI is being played outside Audacity I’d expect it would not matter what the Audacity output is set to. But in practice if you record the built-in speakers or headphones under WASAPI it often errors unless you set the output to the same device as the (loopback) input.