Can no longer import MP4 files into Aucacity

I recently got a new computer, and am using 2.0.5 (my old computer had an older version). I have ffmpeg installed and located. Whenever I try to import a MP4 video file like I used to, I get the message “[file] is an Advanced Audio Coding file. Audacity cannot open this type of file. You need to convert it to a supported format, such as WAV or AIFF.”

I’m not sure what I can do. Does the new version not allow MP4s?

I don’t know what the problem is, but the new version should work too.

I assume you didn’t open this exact file with the old version of Audacity? Have you tried an MP4 file that worked before?

Try running [u]Mediainfo[/u] to determine the audio format that’s contained in your MP4 video file. It’s probably AAC, but maybe it’s something different this time.

There are other tools that can extract audio from an audio/video file, but let’s not give up on Audacity just yet…

Get the version of MediaInfo without installer, because the installer may have malware or adware.

What does Help > Show Log… say in Audacity after you import the file?


I’ve tried multiple MP4s, and all give me the same message. These are videos that I’ve downloaded from YouTube, and I am obtaining them in the same means that I always have. Therefore I don’t think I need to run Mediainfo. There are indeed other ways to get audio from a video on YouTube, but I find this method with Audacity keeps the quality, whereas converting programs seem to compress everything.

Here’s the log:

10:30:35 AM: FFmpeg libraries loaded successfully.
10:30:53 AM: File name is C:UsersUserDownloadsfile.mp4
10:30:53 AM: Mime type is *
10:30:53 AM: Opening with libav
10:30:53 AM: Opening with libsndfile
10:30:53 AM: Opening with liboggvorbis
10:30:53 AM: Opening with libflac
10:30:53 AM: Opening with lof
10:30:53 AM: Error: Importer::Import: Opening failed.

Do you have any old MP4 files that previously imported OK? If so, does Audacity still import them OK? If so, then what is the difference between your old MP4 files and your new MP4 files? (MediaInfo may answer that final question).

First we assume you have the copyright holders’ permission to download from YouTube.

Second, are you using the same FFmpeg version you used before? Audacity 2.0.5 should work with FFmpeg 0.5 but ideally you should be using FFmpeg 0.6.2 from .

Has the downloading method you use changed version? Are you choosing a different file quality amongst the YouTube file versions it offers you?