Can I extract audio from the data files with no .aup

I have recorded 50 or minutes of audio on a USB memory stick using Save project as. This took a considerable length of time to transfer ( longer than the original recordings, thus making me miss half the recording :frowning: ) , but completed successfully from audacities point of view ( no error messages clean shut down after the save). I have tried to open the data using the original windows machine (audacity 2.0.2)and it fails. I have tried moving all the data to a linux machine (2.0.0) but the copy fails with I/O Error as documented elsewhere. Chkdsk on the original machine was recommended but all this has done is wipe out the .aup file and because of the copying problems I’ve not managed to make a backup of this file :frowning:

I can import raw data and have renamed the files to allow sequential import. The alternate files make up stereo pairs and the make stereo pairs function joins the left and right correctly and they set rate returns them to the original 48000 sample rate.
However every audio clip seems to have a splash of noise on the start which makes it impossible to get a clean join between the clips.
Has anyone any idea how I might reconstruct these clips as this ( as ever ) is a once only recording of a string quartet.

I have recorded successfully on exactly the same machine using linux in this fashion and it has worked flawlessly. Proof that if you make ANY change in your techniques check them out before hand. :frowning:




Linux version 3.2.0-34-generic-pae (buildd@roseapple) (gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu5) ) #53-Ubuntu SMP Thu Nov 15 11:11:12 UTC 2012 (Ubuntu 3.2.0-34.53-generic-pae 3.2.33)

Do you mean that every .AU file has a splash of noise at the beginning?
If so, could you post a couple of sequential .AU files for us to look at.

I believe I have 4 renamed files from /e00/d00 these are the first two audio clips.

They are sampled at 48000 and I can’t get a clean merge. I’ve tried swapping left for right to see if that was the problem.

I;ve copied these from thre original data using.

mkdir "renamed" | find -type f -name "*.au" -printf "cp %h/%f renamed/%h/%TY%Tm%Td-%TH%TM%TS_%fn"|sh

Apologies if the files ain’t there. I’m new to the upload tool and it claims
I have tried uploading using name *.au *.bu and *.txt all are disallowed extensions.
What should I use to trick it…? :slight_smile:

.au files should now be allowed.

Sadly, now it’s complaining that the files are too big… (1,060,956 bytes)

Doh! In that case, perhaps you could use a free file sharing service such as sendspace.com.

The first 10 files uploaded to sendspace
http://www.sendspace.com/filegroup/FHBdFkc4q%2F%2B2yugE42rJRljCNJDCXCMAIRvJOhnVX4LYYznns%2FWd4AZN50px1%2FyZja9YLq%2F%2FlkCZaIQ8GTPxAg

That link is dead.

Gale

Exactly how did you merge the AU files having got them in the correct alternate order?


Gale

The link worked for me but not from inside the textarea. here is a new link http://bit.ly/ZCGkn2

I have checked this link so I believe its’ ok.

I have imported the clips into audacity using raw data import, bonded the two sections together with make stereo track and then selected a lower track completely by double pressing in the track and copied that. I then move to the original track and locate the cursor to the end of the clip using the edit function and then paste the clipboarded track onto the end of the top track. The music sounds relevant but there is a splash of noise as the join is crossed. Examing the tracks there seems to be a splash of noise on the start of them which I hear as I play them.

Obviously I’ve got a lot of clips to stitch together and I could well be doing something wrong, I’ve tried swapping the stereo tracks to see if that was a cause of the mix up, but it made no difference. Obviously discovering I’d done something foolish and simplistic would be a cause of great relief to me.

Thanks in anticipation.

Use “File > Import > Audio” rather than import raw.
Here’s the first 6 au files joined together:

Thanks for that. I’ll give it a go this evening.

Well that seems to work as predicted. But there is one caveat; every once in a while 2 or 3 times during a three minute piece, the stereo audio clips are the wrong way round. Left is right and right is left. Obviously with cello and viola on one side and two violins on the other there is a noticeable change in sound which flips back on a later pair of clips, and obviously a click.

I used the aforementioned script to time tag the clips, does Audacity always write one channel before the other or can it reverse it for some reason?

I used audio import with multiple selection of files to import all the clips (very handy!) and then worked down the clips making them stereo pairs and then changed the sample rate to 48000. I thus had a couple of hundred tracks which I used cut ( Control-x) to select individually, and then selected the top track, pressed End to move to the end of the track and Control V to paste the stereo clip in, Home to go back to the start and selected the next stereo clip and onwards.
Each clip remained as an individually selectable item in the top track until I joined them all.
Given this situation is there a way of flipping the L&R tracks of a clip in this top track so I don’t have to check each individual track for correct orientation before pasting them all together? To just select and errant pasted clip and press Reverse ( or similar) would certainly save much effort in such a situation.

Or have I made some mistake in importing, stereo-izing, cutting, pasting or joining?

As far as I’m aware Audacity writes L, R, L, R …

Try the “Channel Mixer” plug-in: http://wiki.audacityteam.org/wiki/Nyquist_Effect_Plug-ins#Channel_Mixer

As far as I’m aware Audacity writes L, R, L, R …

Except for at least the first two which are picture files. That’s where the blue waves come from.
Koz