CALF not working anymore

Hi there, i’m using linux debian audacity 2.3.3-alpha-Nov 22 2019 - cannot load CALF plugins … Previous version of audacity did not work - pre-previous yes. If you launch calf standalone it works so it seems an audacity problem… Please somebody can give any advice/hint to solve?

Seems to work OK for me with Xubuntu 18.04 LTS, Audacity 2.3.3 (release version) and Calf 0.0.60-5 (Ubuntu repository version).


Hi thanks for posting.
I have calf-plugins version 0.90.3-1+b1 debian repository.
Problem is: “cannot load library”
I am trying to figure out why the library cannot be loaded - as the library is there - and the simbolic links - all seems to be there…

Just another thing… could you be so kind and post the screenshot of the window with the library path of the plug-ins where a CALF plug in appears?
(menu effect, add remove pllug-in)
It’s to see if the library setting has something to do with it.
thanks in advance. and are in /usr/lib/calf/
There is also a load of stuff in /usr/share/calf/

Have you tested to see if Ardour can load the calf plug-ins?

Yes i knew it, but i wanted to know if you have the library path in the fields on the right or an URL with http:… because it seems related with the problem.

Do you mean this:


Thanks! I see i have the same setup. So i should search further.

p.s. sorrily nothing from the programmers - i mean - they could at least make some check because it’s a strange behaviour which cannot be easily solved in a forum…

Have you tested with Ardour? If the problem exists there too, then the problem is most likely to be due to a build fault in the Debian package, in which case it should be reported to Debian.

HI, ok i tryed on ardour and they load and work… so … it’s a audacity problem… but which…???

As a workaround, you could use the Calf as stand alone, and connect it into Audacity with Jack Audio.
The workaround is a bit clunky as it means that you will need to “bounce” tracks through Calf onto a new track to use the effects, but the benefit is that you get “real time” control of the effect.

Where did that version come from? Did you build it yourself from the source code?


After some DAYS OF WORK i found out how to make calf works with audacity in Ubuntu 20.04.

You have to use the following packages:


calf (0.60)

audacity 2.2.2

You have to install it in this order.
Before start, you have to uninstall calf and audacity packages.


OS Ubuntu Studio 20
Audacity 2.3.3
Calf Plugins Dont Working.

I just updated to 20.04 (Ubuntu but actually KDE Neon). I am using the KXStudio repositories to install plugin. Many are working but a whole lot are not.

So, this is 2.3.3. I’m guessing it’s an issue with that version of Audacity, but I don’t know.

I’m attaching some screenshots. The “Enabled” one is the first page of many plugins that are working. The other 3 are the first 3 of many that failed. Calf is in that list among many others. I don’t know what the distinction is between those that are working and those that are failing.

These are the Calf plug-ins on Ubuntu 18.04 LTS (installed from the main repo), with Audacity 2.4.0


OS Ubuntu Studio 20.04.3 LTS
Audacity 3.0.2
Calf Plugins Gui Dont Working.

Try the Audacity 3.0.5 AppImage: Audacity ® | Downloads

(Limitation: Jack is not yet supported by the AppImage version)

Linux distro here is MX-19.4_base_x64 (based on Debian GNU/Linux 10) w/Kernel 4.19.0-18. I recently downloaded audacity-linux-3.1.1-x86_64.AppImage via the Audacity Download page, and took it for a test drive. It seems to work fine with either ALSA or JACK (qjackctl-0.9.5-49.1.x86_64.AppImage), despite JACK not being supported. However, the CALF situation is another story. After enabling Calf Equalizer 5 Band, every attempt to open it results in an error message “Couldn’t instantiate effect”. Actually, that’s not quite true, and here’s where it gets interesting - I did get it to work, under the following conditions: Fresh install of Audacity (deleting old audacity & .audacity-data, then downloading/activating/launching a fresh copy of 3.1.1 appimage, importing & selecting a FLAC file and enabling/opening Calf EQ), after which all goes well during the initial session - the full CALF EQ GUI comes up and all controls work as expected, including Preview and Apply. Unfortunately, after that first session it’s all downhill - nothing but error messages, as previously described. It would seem that something gets lost in the act of exiting that first session (maybe CALF glimpses a reflection of itself and realizes it’s nothing but FLAC backwards!).

The fresh install trick has worked only twice so far, but my two brushes with success have left me wanting more. Audacity with a fully functioning collection of CALF plugins would be an audio powerhouse! I’m hoping someone on the Audacity team can look into this.

Thank you very much! In these versions of Audacity plugins work, but not all! For example the Calf Stereo Tools plugin does not work. Although it is visible in other programs. Why is that?