bypassing USB port for USB turntable

Hello. I have a Gem Sound USB turntable which used to work fine in Audacity on my previous computer. It was not easy setting it up. I eventually got a new computer and I cannot get it to recognize the turntable. Tried everything. Read a million posts. I have an RCA to phono plug cable and decided to plug the cable into the mic in jack on front of the computer. I brought up Audacity and it is working. Will I achieve the same result by doing it this way ? There was no audio-codec option in preferences no matter what I did with this computer. Is this an OK way to use the turntable ?

mic in jack on front of the computer.

The Mic-In jack is not a general purpose Audio Input. For one thing it’s mono, not stereo and it’s easy to distort the sound.

Windows can’t find the turntable if you plug it in and go to Windows Control Panels? Forget Audacity for a while. If Windows can’t find it, Audacity will never be able to see it.

Did you get a driver disk or information for your turntable? Is it available on-line?

If your turntable has good, corrected stereo out on two RCA cables, you can use a Behringer UCA-202 to put the show into your computer.


Like Koz says, Audacity only see what Windows see. You will first have to get windows to reconize the turntable,

I have a Gem Sound USB turntable which used to work fine in Audacity on my previous computer.

Sounds like you have an older turntable. If so again like Said you will have to get the drivers, after Windows sees it the Audacity will.

A driver disk did not come with the turntable. I received 2 discs- Audacity and a BIAS SOUNDSOAP program disc to clean up the LP’s. In my first computer, the turntable was detected. In Audacity under preferences and devices, AUDIO CODEC option was present and everything did work fine. I have no idea how to find drivers. What is a Behringer UCA-202 ?

You still need to forget Audacity for a while. Leave it closed.

Connect the turntable. Let Windows chew on it for a minute.

In Windows:
Start > Control Panels > Audio (or Sound) > Recording.

Look for a listing for USB Audio Device, Audio Codec, or something similar. If you don’t have that, then Windows didn’t find the turntable and Audacity won’t find it either.

I’m not the Windows guru, so I’m doing this from memory using a machine at work.

A Behringer UCA202 is a simple, inexpensive stereo audio adapter. It allows you to plug stereo cables into your Windows, or any other kind of machine. As above, most Windows laptops do not have a stereo input. Mic-In is mono.


Koz: I went to the control panel under Audio. What came up is Realtek audio device manager. It recognized the turntable. The turntable appears to be working fine. It is connected via USB cable and is NOT in the mic jack. Now I have to figure out if I can get this other program that cleans up the LP’s to work. Thanks for your help very much.


One more question. Now that the turntable is working through the Realtek Audio Manager via USB, is there a way to now get Audacity to work so I can record and then edit the track. The BIAS Soundsoap program cleans up scratches, hiss, etc. The first step is to record each track in Audacity. Then save it, open up Sounsoap, click on the saved file and custom edit each track. It takes time, but eventually works.

Tell me Mr. RIESEL, what is the Audio Host set at in Audacity, also the Output Device and the input device and the input channels. They should be Audio Host = MME, Output Device (should be your sound card) Output Device = USB Audio Codec.
Is the Soundsoap loading in background? You might try using a program r3emoval Program and remove that until you get everything else running. Is audacity working, you hint that it is but did not say

It recognized the turntable. The turntable appears to be working fine. It is connected via USB cable and is NOT in the mic jack.

Hope this helps, Marty

Audio Host is MME. Output device = speakers-Realtek; Input= mic-Realtek; input channels= 2- stereo. There is no audio-codec anywhere. Now that the turntable is working through Realtek audio mgr in my Windows 7, I tried last night to use audacity. When I hit the monitor button, the sound of the LP was very scratchy and garbled.

Sorry sir, i do not know to much about win 7 (I use XP) but somewhere in the Audio there should be a USB Audio Codex or USB Audio Input or something like that if the turntable is being seen by Windows. Again for win 7 i do not know. Maybe one of the better users of the forum can help you with that, sorry Marty

Can we go back a couple of steps…

In order to record from the USB input, Koz is quite correct in that the USB device must be recognised (and enabled) in Windows, otherwise Audacity will not be able to use it.
See here for how to view the recording inputs that Windows knows about Missing features - Audacity Support
Is there a USB option listed?
Is the option greyed out?