Burned CD contains only half the track

I have been through the tutorial (it is great, by the way) and have successfully edited and separated a recording into tracks, but for some reason only about half of the track is converted and burned to the CD. I have successfully used Audacity to convert tapes to CD and burned them with great results–no problems. I am only having this problem when I try to convert recordings made and loaded to my PC from an RCA digital voice recorder. When I try to burn a CD from the digital recorder (after converting to the proper format) the CD tracks play fine, but only the first half of each track is there. If the track is 4 minutes long, it shows as 4 minutes in audacity and it all plays in Audacity, but when I save it to my PC file it only shows up as about 2 minutes in my saved file and then when I burn it only the first 2 minutes is there. It is just that when I save these digital voice recordings (after being converted to 16 bit and a bit rate of 44100) to my PC file so I can burn to CD each track is only half there.

I have Windows XP, burning the CD with RecordNow 5.0, using Audacity 2.0., recordings were made on an RCA 5120-A digital recorder.

Please forgive me if this problem has already been dealt with here, but I have searched the FAQ several times and have not found anything like this. Thank you in advance for any assistance you may be able to provide.

I had a cousin to that problem. I have a really early CD burning program that hated mono sound files. I would cheerfully burn a Music CD and get it to the car and it would play 30 minutes of an hour show and stop dead.

Are you exporting stereo sound files even though the sound capture recorder is probably producing mono sound files?


That thought occurred to me too, but I don’t think that is it. I can play the full exported recording on my PC. As an example, I just now played a recording on my PC that I had recorded on my digital recorder, converted to 16 bit in Audacity and exported back to a saved file on my PC. It played all 2:26 minutes of it. I then browsed and selected the same file in RecordNow to burn it. RecordNow showed the recording to be 1:12 long. The problem seems to occur when I select the file in RecordNow to burn it. But, I don’t have this problem with RecordNow on other music files I burn to CD if they are copied from another CD or copied from tape and exported using Audacity, it only happens with the files from the digital recorder.

Any other thoughts on what to try would be appreciated. Thanks!

How are you converting the files in the digital recorder before you import them into Audacity - what format are those files in? Does RecordNow see those files as half length before you use Audacity?

Can you not use Windows Media Player or iTunes to burn the files that originate from the digital recorder?


If I attempt to burn before I change the format in Audacity, RecordNow stops me and tells me that it is in the wrong format. So I can’t see what the length is. But, I tried burning the CD in Windows Media Player and it worked!!! This is the first time I have experimented with Media Player. I had always before gotten good results with RecordNow, but this seems to be the workaround solution to the ultimate goal of burning the CD. I still am puzzled by the problem with RecordNow, but apparently the problem is with RecordNow and not Audacity. Thanks for the suggestion!

This puzzles me - I use RecordNow (v6.5.3) all the time on my desktop running Windows XP-HE-SP3 and I never have a problem with it. :confused: