Bug with pasting over clips in 3.4.0?


Or you can right-click in the waveform - and in the waveform context menu there is also a Join Clips command (slightly easier).

In the Full set of shortcuts (non-default) there is Ctrl+J (Cmd+J on Mac) shortcut for Join Clips. For 3.4.1 this is being moved to the Standard (default) set of shortcuts.

In the meantime you can create a custom shortcut for Join Clips in Keyboard preferences. Personally if I was doing clip joining a lot I would set a single-key shortcut for it.

And that’s one of the key reasons the the left-click join was removed, It also made it impossible to select at the join.